summaryrefslogtreecommitdiff
path: root/packages/gnumeric/gnumeric_1.6.3.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-04-06 22:39:32 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-06 22:39:32 +0000
commit6c97f56d28872da36cc0cc52631668985d8db22a (patch)
tree3957d53afc5c22540dedd5c61af13b28149a5b55 /packages/gnumeric/gnumeric_1.6.3.bb
parent3bcd16909c945940017ded43f94652f1a7acf2f5 (diff)
parent254167bc41a3aae1c45a5f769ec16dee2dd37e2e (diff)
merge of 5945a66a6847c21d25595376695c23f3971f6f8a
and e544df2d6779a2a53f1c47a6d1e1961d875d17af
Diffstat (limited to 'packages/gnumeric/gnumeric_1.6.3.bb')
-rw-r--r--packages/gnumeric/gnumeric_1.6.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/gnumeric/gnumeric_1.6.3.bb b/packages/gnumeric/gnumeric_1.6.3.bb
new file mode 100644
index 0000000000..0fc45bbd63
--- /dev/null
+++ b/packages/gnumeric/gnumeric_1.6.3.bb
@@ -0,0 +1,22 @@
+LICENSE = "GPL"
+SECTION = "x11/utils"
+S = "${WORKDIR}/gnumeric-${PV}"
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+DEPENDS = "libgsf gtk+ libxml2 goffice libglade libart-lgpl intltool-native libgnomecanvas libgnomeprint libgnomeprintui libbonoboui"
+DESCRIPTION = "Gnumeric spreadsheet for GNOME"
+
+inherit gnome flow-lossage
+
+SRC_URI += "file://remove-docs.patch;patch=1"
+
+EXTRA_OECONF=" --without-perl "
+
+PACKAGES_DYNAMIC = "gnumeric-plugin-*"
+
+FILES_gnumeric_append = " /usr/lib/libspreadsheet-${PV}.so "
+
+python populate_packages_prepend () {
+ gnumeric_libdir = bb.data.expand('${libdir}/gnumeric/${PV}/plugins', d)
+
+ do_split_packages(d, gnumeric_libdir, '(.*)', 'gnumeric-plugin-%s', 'Gnumeric plugin for %s', allow_dirs=True)
+}