summaryrefslogtreecommitdiff
path: root/packages/gnome
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-01-27 10:31:36 +0000
committerKoen Kooi <koen@openembedded.org>2005-01-27 10:31:36 +0000
commita7765532e369e9cc71cba862ac06fbcd70b4f6e5 (patch)
tree98cb17a50dfa466ee7f8a17173504756d4d9a24c /packages/gnome
parentba99030521dcea3a1efae629dc63a757592a84e3 (diff)
remove stray libxml dep from gconf-dbus_cvs.bb
BKrev: 41f8c308zNlXAtVO8_8yQ2jJsLH_vg
Diffstat (limited to 'packages/gnome')
-rw-r--r--packages/gnome/gconf-dbus_cvs.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/gnome/gconf-dbus_cvs.bb b/packages/gnome/gconf-dbus_cvs.bb
index e69de29bb2..971867b8c1 100644
--- a/packages/gnome/gconf-dbus_cvs.bb
+++ b/packages/gnome/gconf-dbus_cvs.bb
@@ -0,0 +1,31 @@
+SECTION = "x11/utils"
+DEPENDS = "gtk+ glib-2.0 dbus"
+DESCRIPTION = "Settings daemon using DBUS for communication."
+LICENSE = "GPL"
+MAINTAINER = "Florian Boor <florian@kernelconcepts.de>
+PROVIDES = "gconf"
+RPROVIDES = "gconf"
+
+PV = "0.0cvs${CVSDATE}"
+PR = "r3"
+
+SRC_URI = "cvs://anonymous@anoncvs.gnome.org/cvs/gnome;module=gconf;tag=gconf-dbus-2-6 \
+ file://gconf-dbus-update.patch;patch=1;pnum=0"
+
+FILES_${PN} += " ${libdir}/GConf/2/*.so ${libdir}/dbus-1.0"
+
+S = "${WORKDIR}/gconf"
+
+
+inherit pkgconfig autotools
+
+EXTRA_OECONF = " --with-ipc=dbus --disable-gtk-doc --enable-gtk --host=${HOST_SYS} --enable-shared --disable-static"
+
+HEADERS = "gconf.h gconf-changeset.h gconf-listeners.h gconf-schema.h gconf-value.h gconf-error.h gconf-engine.h gconf-client.h gconf-enum-types.h"
+
+do_stage() {
+ oe_libinstall -so -C gconf libgconf-2 ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/gconf/2/gconf/
+ ( cd gconf; for i in ${HEADERS}; do install -m 0644 $i ${STAGING_INCDIR}/gconf/2/gconf/$i; done )
+ install -m 0644 gconf.m4 ${STAGING_DATADIR}/aclocal/gconf-2.m4
+}