summaryrefslogtreecommitdiff
path: root/packages/gnome
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-04-12 08:15:57 +0000
committerKoen Kooi <koen@openembedded.org>2007-04-12 08:15:57 +0000
commit797d987e5133f3579163b3cead61b9917a1d9390 (patch)
tree8ffe5a96074021225706348aa9472bd3fa5fc48a /packages/gnome
parenteaf84f9d5a95bae2054ee7438905d05d7836370c (diff)
gconf-dbus: update svn to 2.16
Diffstat (limited to 'packages/gnome')
-rw-r--r--packages/gnome/gconf-dbus_svn.bb27
1 files changed, 12 insertions, 15 deletions
diff --git a/packages/gnome/gconf-dbus_svn.bb b/packages/gnome/gconf-dbus_svn.bb
index 87daa1d227..0bb9765749 100644
--- a/packages/gnome/gconf-dbus_svn.bb
+++ b/packages/gnome/gconf-dbus_svn.bb
@@ -6,13 +6,10 @@ PROVIDES = "gconf"
RPROVIDES_${PN} = "gconf"
RPROVIDES_${PN}-dev = "gconf-dev"
-PV = "2.10.0+svn${SRCDATE}"
+PV = "2.16.0+svn${SRCDATE}"
PR = "r0"
SRC_URI = "svn://developer.imendio.com/svn/gconf-dbus;module=trunk;proto=http \
- file://gconf-dbus-update.patch;patch=1;pnum=0 \
- file://xml-backend-locks-compile-fix.patch;patch=1 \
- file://xml-backend-oldxml-Makefile.patch \
file://69gconfd-dbus"
inherit pkgconfig autotools
@@ -20,23 +17,22 @@ S = "${WORKDIR}/trunk"
PARALLEL_MAKE = ""
-FILES_${PN} += " ${libdir}/gconf-dbus/2/*.so ${libdir}/dbus-1.0 ${sysconfdir} ${datadir}/dbus*"
-FILES_${PN}-dbg += "${libdir}/gconf-dbus/2/.debug"
+FILES_${PN} += " ${libdir}/gconf-dbus/2/*.so \
+ ${libdir}/GConf-dbus/2/*.so \
+ ${libdir}/dbus-1.0 \
+ ${sysconfdir} \
+ ${datadir}/dbus*"
+FILES_${PN}-dbg += "${libdir}/gconf-dbus/2/.debug \
+ ${libdir}/GConf-dbus/2/.debug ""
EXTRA_OECONF = " --with-ipc=dbus --disable-gtk-doc --enable-gtk --host=${HOST_SYS} --enable-shared --disable-static"
-HEADERS = "gconf.h gconf-changeset.h gconf-listeners.h gconf-schema.h gconf-value.h gconf-error.h gconf-engine.h gconf-client.h gconf-enum-types.h"
-
-do_compile_prepend() {
- cd ${S}
- patch -p1 < ../xml-backend-oldxml-Makefile.patch
+do_configure_prepend() {
+ touch ${S}/gtk-doc.make
}
do_stage() {
- oe_libinstall -so -C gconf libgconf-2 ${STAGING_LIBDIR}
- install -d ${STAGING_INCDIR}/gconf/2/gconf/
- ( cd gconf; for i in ${HEADERS}; do install -m 0644 $i ${STAGING_INCDIR}/gconf/2/gconf/$i; done )
- install -m 0644 gconf.m4 ${STAGING_DATADIR}/aclocal/gconf-2.m4
+ autotools_stage_all
}
do_install_append () {
@@ -45,3 +41,4 @@ do_install_append () {
install -d ${D}/${datadir}/dbus-1.0/services/
install -m 644 gconf/gconf.service ${D}${datadir}/dbus-1.0/services/
}
+