summaryrefslogtreecommitdiff
path: root/packages/gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2008-12-10 12:08:42 -0800
committerKhem Raj <raj.khem@gmail.com>2008-12-10 12:08:42 -0800
commitc83835dca4b2a8f8267066037c86a71474f278c2 (patch)
treeb8645ff1fa623a7b8ce5496a62c2f2a01fd87887 /packages/gnome
parentfca5cadc1e2012f01afcdd67d9482a4c52aa52d1 (diff)
parent1a184ff3d7b13923c4b7cd94866307ac8f399bed (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'packages/gnome')
-rw-r--r--packages/gnome/gdm/cross-xdetection.diff84
-rwxr-xr-xpackages/gnome/gdm/gdm73
-rw-r--r--packages/gnome/gdm/gdm.conf80
-rw-r--r--packages/gnome/gdm_2.24.1.bb49
-rw-r--r--packages/gnome/gnome-power-manager_2.24.2.bb36
5 files changed, 319 insertions, 3 deletions
diff --git a/packages/gnome/gdm/cross-xdetection.diff b/packages/gnome/gdm/cross-xdetection.diff
new file mode 100644
index 0000000000..9cb6ac98dd
--- /dev/null
+++ b/packages/gnome/gdm/cross-xdetection.diff
@@ -0,0 +1,84 @@
+--- /tmp/configure.ac 2008-12-10 08:38:16.000000000 +0100
++++ gdm-2.24.1/configure.ac 2008-12-10 08:39:17.000000000 +0100
+@@ -1133,80 +1133,10 @@
+ dnl - Check for X Server location
+ dnl ---------------------------------------------------------------------------
+
+-# First check with "! -h" for /usr/X11R6 and /usr/X11 since they often
+-# symlink to each other, and configure should use the more stable
+-# location (the real directory) if possible.
+-#
+-# On Solaris, the /usr/bin/Xserver script is used to decide whether to
+-# use Xsun or Xorg, so this is used on Solaris.
+-#
+-# When testing for /usr/X11R6, first check with "! -h" for /usr/X11R6
+-# and /usr/X11 since they often symlink to each other, and configure
+-# should use the more stable location (the real directory) if possible.
+-#
+-if test -x /usr/X11/bin/Xserver; then
+- X_PATH="/usr/X11/bin"
+- X_SERVER_PATH="/usr/X11/bin"
+- X_SERVER="/usr/X11/bin/Xserver"
+- GDM_USER_PATH="$GDM_USER_PATH:/usr/X11/bin"
+- X_CONFIG_OPTIONS="-audit 0"
+-elif test ! -h /usr/X11R6 -a -x /usr/X11R6/bin/X; then
+- X_PATH="/usr/X11R6/bin"
+- X_SERVER_PATH="/usr/X11R6/bin"
+- X_SERVER="/usr/X11R6/bin/X"
+- GDM_USER_PATH="$GDM_USER_PATH:/usr/X11R6/bin"
+- X_CONFIG_OPTIONS="-audit 0"
+-elif test ! -h /usr/X11 -a -x /usr/X11/bin/X; then
+- X_PATH="/usr/X11/bin"
+- X_SERVER_PATH="/usr/X11/bin"
+- X_SERVER="/usr/X11/bin/X"
+- GDM_USER_PATH="$GDM_USER_PATH:/usr/X11/bin"
+- X_CONFIG_OPTIONS="-audit 0"
+-elif test -x /usr/X11R6/bin/X; then
+- X_PATH="/usr/X11R6/bin"
+- X_SERVER_PATH="/usr/X11R6/bin"
+- X_SERVER="/usr/X11R6/bin/X"
+- GDM_USER_PATH="$GDM_USER_PATH:/usr/X11R6/bin"
+- X_CONFIG_OPTIONS="-audit 0"
+-elif test -x /usr/bin/Xorg; then
+ X_PATH="/usr/bin"
+ X_SERVER_PATH="/usr/bin"
+- X_SERVER="/usr/bin/Xorg"
+- X_CONFIG_OPTIONS="-audit 0"
+-elif test -x /usr/X11/bin/X; then
+- X_PATH="/usr/X11/bin"
+- X_SERVER_PATH="/usr/X11/bin"
+- X_SERVER="/usr/X11/bin/X"
+- GDM_USER_PATH="$GDM_USER_PATH:/usr/X11/bin"
+- X_CONFIG_OPTIONS="-audit 0"
+-elif test -x /usr/openwin/bin/Xsun; then
+- # Do not add /usr/openwin/bin here because on Solaris you need
+- # /usr/openwin/bin in your PATH even if you are using the Xorg
+- # Xserver. We add this to the path below.
+- X_PATH="/usr/openwin/bin"
+- X_SERVER_PATH="/usr/openwin/bin"
+- X_SERVER="/usr/openwin/bin/Xsun"
+- X_CONFIG_OPTIONS="-audit 0 -nobanner"
+-elif test -x /opt/X11R6/bin/X; then
+- X_PATH="/opt/X11R6/bin"
+- X_SERVER_PATH="/opt/X11R6/bin"
+- X_SERVER="/opt/X11R6/bin/X"
+- GDM_USER_PATH="$GDM_USER_PATH:/opt/X11R6/bin"
+- X_CONFIG_OPTIONS="-audit 0"
+-elif test -x /usr/bin/X; then
+- X_PATH="/usr/bin"
+- X_SERVER_PATH="/usr/bin"
+- X_SERVER="/usr/bin/X"
+- X_CONFIG_OPTIONS="-audit 0"
+-else
+- # what to do, what to do, this is wrong, but this just sets the
+- # defaults, perhaps this user is cross compiling or some such
+- X_PATH="/usr/bin/X11:/usr/X11R6/bin:/opt/X11R6/bin"
+- X_SERVER_PATH="/usr/X11R6/bin"
+- X_SERVER="/usr/X11R6/bin/X"
+- GDM_USER_PATH="$GDM_USER_PATH:/usr/bin/X11:/usr/X11R6/bin:/usr/local/bin:/opt/X11R6/bin"
++ X_SERVER="/etc/X11/Xserver"
+ X_CONFIG_OPTIONS="-audit 0"
+-fi
+
+ # Don't add bindir to GDM_USER_PATH if it is already in the PATH.
+ # If it is /bin or /usr/bin, for example.
diff --git a/packages/gnome/gdm/gdm b/packages/gnome/gdm/gdm
new file mode 100755
index 0000000000..0d43a6f91a
--- /dev/null
+++ b/packages/gnome/gdm/gdm
@@ -0,0 +1,73 @@
+#! /bin/sh
+### BEGIN INIT INFO
+# Provides: gdm
+# Should-Start: console-screen acpid dbus hal network-manager
+# Required-Start: $local_fs $remote_fs
+# Required-Stop: $local_fs $remote_fs
+# Default-Start: 2 3 4 5
+# Default-Stop: 0 1 6
+# Short-Description: GNOME Display Manager
+# Description: Debian init script for the GNOME Display Manager
+### END INIT INFO
+#
+# Author: Ryan Murray <rmurray@debian.org>
+#
+set -e
+
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+DAEMON=/usr/sbin/gdm
+
+test -x $DAEMON || exit 0
+
+if [ -r /etc/default/locale ]; then
+ . /etc/default/locale
+ export LANG LANGUAGE
+fi
+
+# To start gdm even if it is not the default display manager, change
+# HEED_DEFAULT_DISPLAY_MANAGER to "false."
+HEED_DEFAULT_DISPLAY_MANAGER=true
+DEFAULT_DISPLAY_MANAGER_FILE=/etc/X11/default-display-manager
+
+case "$1" in
+ start)
+ CONFIGURED_DAEMON=$(basename "$(cat $DEFAULT_DISPLAY_MANAGER_FILE 2> /dev/null)")
+ if grep -wqs text /proc/cmdline; then
+ echo "Not starting GNOME Display Manager (gdm); found 'text' in kernel commandline."
+ elif [ -e "$DEFAULT_DISPLAY_MANAGER_FILE" ] && \
+ [ "$HEED_DEFAULT_DISPLAY_MANAGER" = "true" ] && \
+ [ "$CONFIGURED_DAEMON" != gdm ] ; then
+ echo "Not starting GNOME Display Manager; it is not the default display manager"
+ else
+ echo "Starting GNOME Display Manager" "gdm"
+ start-stop-daemon --start --quiet --exec $DAEMON
+ fi
+ ;;
+ stop)
+ echo "Stopping GNOME Display Manager" "gdm"
+ set +e
+ start-stop-daemon --stop --quiet --pidfile /var/run/gdm.pid \
+ --name gdm --retry 5
+ set -e
+ ;;
+ reload)
+ echo "Scheduling reload of GNOME Display Manager configuration" "gdm"
+ set +e
+ start-stop-daemon --stop --signal USR1 --quiet --pidfile \
+ /var/run/gdm.pid --name gdm
+ set -e
+ ;;
+ status)
+ status_of_proc -p "$PIDFILE" "$DAEMON" gdm && exit 0 || exit $?
+ ;;
+ restart|force-reload)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "Usage: /etc/init.d/gdm {start|stop|restart|reload|force-reload|status}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/packages/gnome/gdm/gdm.conf b/packages/gnome/gdm/gdm.conf
new file mode 100644
index 0000000000..559823b863
--- /dev/null
+++ b/packages/gnome/gdm/gdm.conf
@@ -0,0 +1,80 @@
+# GDM Custom Configuration file.
+#
+# This file is the appropriate place for specifying your customizations to the
+# GDM configuration. If you run gdmsetup, it will automatically edit this
+# file for you and will cause the daemon and any running GDM GUI programs to
+# automatically update with the new configuration. Not all configuration
+# options are supported by gdmsetup, so to modify some values it may be
+# necessary to modify this file directly by hand.
+#
+# This file overrides the default configuration settings. These settings
+# are stored in the GDM System Defaults configuration file, which is found
+# at the following location.
+#
+# /usr/share/gdm/defaults.conf.
+#
+# This file contains comments about the meaning of each configuration option,
+# so is also a useful reference. Also refer to the documentation links at
+# the end of this comment for further information. In short, to hand-edit
+# this file, simply add or modify the key=value combination in the
+# appropriate section in the template below this comment section.
+#
+# For example, if you want to specify a different value for the Enable key
+# in the "[debug]" section of your GDM System Defaults configuration file,
+# then add "Enable=true" in the "[debug]" section of this file. If the
+# key already exists in this file, then simply modify it.
+#
+# Older versions of GDM used the "gdm.conf" file for configuration. If your
+# system has an old gdm.conf file on the system, it will be used instead of
+# this file - so changes made to this file will not take effect. Consider
+# migrating your configuration to this file and removing the gdm.conf file.
+#
+# If you hand edit a GDM configuration file, you can run the following
+# command and the GDM daemon will immediately reflect the change. Any
+# running GDM GUI programs will also be notified to update with the new
+# configuration.
+#
+# gdmflexiserver --command="UPDATE_CONFIG <configuration key>"
+#
+# e.g, the "Enable" key in the "[debug]" section would be "debug/Enable".
+#
+# You can also run gdm-restart or gdm-safe-restart to cause GDM to restart and
+# re-read the new configuration settings. You can also restart GDM by sending
+# a HUP or USR1 signal to the daemon. HUP behaves like gdm-restart and causes
+# any user session started by GDM to exit immediately while USR1 behaves like
+# gdm-safe-restart and will wait until all users log out before restarting GDM.
+#
+# For full reference documentation see the gnome help browser under
+# GNOME|System category. You can also find the docs in HTML form on
+# http://www.gnome.org/projects/gdm/
+#
+# NOTE: Lines that begin with "#" are considered comments.
+#
+# Have fun!
+
+[daemon]
+
+[security]
+
+[xdmcp]
+
+[gui]
+
+[greeter]
+
+[chooser]
+
+[debug]
+
+# Note that to disable servers defined in the GDM System Defaults
+# configuration file (such as 0=Standard, you must put a line in this file
+# that says 0=inactive, as described in the Configuration section of the GDM
+# documentation.
+#
+[servers]
+
+# Also note, that if you redefine a [server-foo] section, then GDM will
+# use the definition in this file, not the GDM System Defaults configuration
+# file. It is currently not possible to disable a [server-foo] section
+# defined in the GDM System Defaults configuration file.
+#
diff --git a/packages/gnome/gdm_2.24.1.bb b/packages/gnome/gdm_2.24.1.bb
index 24e36f5a11..c04e9aabea 100644
--- a/packages/gnome/gdm_2.24.1.bb
+++ b/packages/gnome/gdm_2.24.1.bb
@@ -1,20 +1,63 @@
DESCRIPTION = "Graphical login manager"
LICENSE = "GPL"
-DEPENDS = "libpam gnome-doc-utils gtk+ libglade libgnomecanvas librsvg libxml2 libart-lgpl"
+DEPENDS = "grep consolekit libpam gnome-doc-utils gtk+ libglade libgnomecanvas librsvg libxml2 libart-lgpl"
-inherit gnome
+PR = "r3"
-SRC_URI += "file://%gconf-tree.xml"
+inherit gnome update-rc.d
+
+SRC_URI += "file://cross-xdetection.diff;patch=1 \
+ file://%gconf-tree.xml \
+ file://gdm.conf \
+ file://gdm \
+ "
+
+EXTRA_OECONF = " --enable-authentication-scheme=shadow \
+ --with-console-kit \
+ --disable-scrollkeeper "
do_install_prepend() {
mkdir -p ${D}/var/lib/gdm/.gconf.mandatory
cp ${WORKDIR}/%gconf-tree.xml ${D}/var/lib/gdm/.gconf.mandatory/
+ install -d ${D}/${sysconfdir}/gdm
+ install -m 0644 ${WORKDIR}/gdm.conf ${D}/${sysconfdir}/gdm/
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/gdm ${D}/${sysconfdir}/init.d/
}
FILES_${PN} += "${datadir}/icon* \
${datadir}/xsession*"
+CONFFILES_${PN} += "${sysconfdir}/gdm/gdm.conf ${sysconfdir}/init.d/gdm"
+
+INITSCRIPT_NAME = "gdm"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
+
+pkg_postinst_${PN} () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+ grep "^gdm:" /etc/group > /dev/null || addgroup gdm
+ grep "^gdm:" /etc/passwd > /dev/null || adduser --disabled-password --system --home /var/lib/gdm gdm --ingroup gdm -g gdm
+
+if [ -d /var/lib/gdm ]; then
+ chown -R gdm:gdm /var/lib/gdm
+ chmod 0750 /var/lib/gdm
+fi
+
+# Register up as default dm
+mkdir -p ${sysconfdir}/X11/
+echo "${bindir}/gdm" > ${sysconfdir}/X11/default-display-manager
+
+}
+
+pkg_postrm_${PN} () {
+ deluser gdm || true
+ delgroup gdm || true
+ sed -i /gdm/d ${sysconfdir}/X11/default-display-manager || true
+}
diff --git a/packages/gnome/gnome-power-manager_2.24.2.bb b/packages/gnome/gnome-power-manager_2.24.2.bb
new file mode 100644
index 0000000000..904cd39364
--- /dev/null
+++ b/packages/gnome/gnome-power-manager_2.24.2.bb
@@ -0,0 +1,36 @@
+LICENSE = "GPLv2"
+DEPENDS = "libnotify libgnomeui gnome-panel gnome-doc-utils libwnck gtk+ gnome-keyring libglade hal dbus-glib "
+
+inherit gnome
+
+EXTRA_OECONF = " --disable-scrollkeeper \
+ --disable-keyring \
+ --x-includes=${STAGING_INCDIR} \
+ --x-libraries=${STAGING_LIBDIR} \
+ --with-dpms-ext=${STAGING_INCDIR}/.. \
+ --enable-compile-warnings=no \
+ ac_cv_header_X11_extensions_dpms_h=yes \
+ "
+
+do_configure_append() {
+ rm config.log
+ # Sigh... --enable-compile-warnings=no doesn't actually turn off -Werror
+ for i in $(find ${S} -name "Makefile") ; do
+ sed -i -e s:-Werror::g $i
+ done
+}
+
+PACKAGES =+ "${PN}-applets"
+
+FILES_${PN}-applets = "${bindir}/*applet* \
+ ${libdir}/bonobo/servers \
+ ${datadir}/gnome-2.0/ui"
+
+FILES_${PN} += "${datadir}/icons \
+ ${datadir}/dbus-1 \
+ ${datadir}/gnome/autostart \
+ "
+
+FILE_{PN}-doc += "${datadir}/omf \
+ ${datadir}/gnome/help "
+