summaryrefslogtreecommitdiff
path: root/packages/gnome/libbonobo_2.10.0.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-07-31 11:43:28 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-31 11:43:28 +0000
commita1beb4cf035284afb8aa641aee559dfd9581c6fd (patch)
tree2d8f6650e034c67df936dd6091550a981308a2ed /packages/gnome/libbonobo_2.10.0.bb
parentf04420fc3411246cd8d2d9e283f6e9073158901b (diff)
update libbonobo to 2.10.0
Diffstat (limited to 'packages/gnome/libbonobo_2.10.0.bb')
-rw-r--r--packages/gnome/libbonobo_2.10.0.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/packages/gnome/libbonobo_2.10.0.bb b/packages/gnome/libbonobo_2.10.0.bb
new file mode 100644
index 0000000000..bd51d4e45a
--- /dev/null
+++ b/packages/gnome/libbonobo_2.10.0.bb
@@ -0,0 +1,59 @@
+LICENSE = "GPL"
+PR = "r1"
+SECTION = "x11/gnome/libs"
+DESCRIPTION = "Bonobo CORBA interfaces library"
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libbonobo/2.10/libbonobo-${PV}.tar.bz2 \
+ file://gtk-doc.m4 \
+ file://gtk-doc.make"
+DEPENDS = "glib-2.0 orbit2 intltool-native libxml2"
+ORBIT_IDL_SRC = "${STAGING_BINDIR}/orbit-idl-2"
+
+FILES_${PN} += "${libdir}/orbit-2.0/*.so ${libdir}/bonobo/monikers/*.so"
+FILES_${PN}-dev += "${libdir}/orbit-2.0/* ${libdir}/bonobo/monikers/* \
+ ${libdir}/bonobo-2.0/samples"
+
+inherit autotools pkgconfig
+
+PARALLEL_MAKE = ""
+
+do_configure_prepend() {
+ install -d m4
+ install ${WORKDIR}/gtk-doc.m4 m4/
+ install ${WORKDIR}/gtk-doc.make ./
+}
+
+ACTIVATION_HEADERS = "Bonobo_Unknown.h Bonobo_GenericFactory.h Bonobo_Activation_types.h \
+ bonobo-activation.h bonobo-activation-async.h bonobo-activation-activate.h \
+ bonobo-activation-init.h bonobo-activation-shlib.h bonobo-activation-register.h \
+ bonobo-activation-server-info.h bonobo-activation-version.h"
+
+BONOBO_HEADERS = "Bonobo.h bonobo-arg.h bonobo-context.h bonobo-event-source.h bonobo-exception.h \
+ bonobo-generic-factory.h bonobo-item-container.h bonobo-item-handler.h \
+ bonobo-listener.h bonobo-main.h bonobo-macros.h bonobo-moniker-extender.h \
+ bonobo-moniker-simple.h bonobo-moniker-util.h bonobo-moniker.h bonobo-object.h \
+ bonobo-foreign-object.h bonobo-persist-file.h bonobo-persist-stream.h \
+ bonobo-persist.h bonobo-persist-client.h bonobo-property-bag.h \
+ bonobo-property-bag-client.h bonobo-shlib-factory.h bonobo-storage.h \
+ bonobo-stream.h bonobo-stream-client.h bonobo-stream-memory.h \
+ bonobo-storage-memory.h bonobo-xobject.h bonobo-i18n.h bonobo-types.h \
+ bonobo-app-client.h bonobo-application.h"
+
+do_compile() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}"
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/bonobo-activation-2.0/bonobo-activation
+ for i in ${ACTIVATION_HEADERS}; do install -m 0644 bonobo-activation/$i ${STAGING_INCDIR}/bonobo-activation-2.0/bonobo-activation/; done
+ install -d ${STAGING_INCDIR}/libbonobo-2.0/bonobo
+ for i in ${BONOBO_HEADERS}; do install -m 0644 bonobo/$i ${STAGING_INCDIR}/libbonobo-2.0/bonobo/; done
+ install -m 0644 libbonobo.h ${STAGING_INCDIR}/libbonobo-2.0/
+ install -d ${STAGING_DATADIR}/idl/bonobo-activation-2.0/
+ install idl/*.idl ${STAGING_DATADIR}/idl/bonobo-activation-2.0/
+ oe_libinstall -so -C bonobo libbonobo-2 ${STAGING_LIBDIR}
+ oe_libinstall -so -C bonobo-activation libbonobo-activation ${STAGING_LIBDIR}
+}
+
+do_install() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
+}