summaryrefslogtreecommitdiff
path: root/packages/gnome/libart-lgpl.inc
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-01-19 18:17:42 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-01-19 18:17:42 +0000
commit0c8c85a59e9e9c80f3b87a2dae13d67f0ddedbe3 (patch)
tree3043e23260837fa8408a5d0c4cf14e4b1fd36141 /packages/gnome/libart-lgpl.inc
parentf01eb970168114981527b662fe07747281c65426 (diff)
libart-lgpl: unify
Diffstat (limited to 'packages/gnome/libart-lgpl.inc')
-rw-r--r--packages/gnome/libart-lgpl.inc30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/gnome/libart-lgpl.inc b/packages/gnome/libart-lgpl.inc
new file mode 100644
index 0000000000..a37b392593
--- /dev/null
+++ b/packages/gnome/libart-lgpl.inc
@@ -0,0 +1,30 @@
+DESCRIPTION = "Library of functions for 2D graphics"
+SECTION = "x11/gnome"
+LICENSE = "LGPL"
+
+ART_CONFIG = "${HOST_ARCH}/art_config.h"
+
+# can't use gnome.oeclass due to _ in filename
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libart_lgpl/2.3/libart_lgpl-${PV}.tar.bz2 \
+ file://${ART_CONFIG} \
+ file://Makefile.am.patch;patch=1"
+
+inherit autotools pkgconfig
+
+DEPENDS = ""
+
+FILES_${PN} = "${libdir}/*.so.*"
+FILES_${PN}-dev += "${bindir}/libart2-config"
+
+S = "${WORKDIR}/libart_lgpl-${PV}"
+
+do_configure_prepend() {
+ cp ${WORKDIR}/${ART_CONFIG} ${S}/art_config.h
+}
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+do_stage() {
+ autotools_stage_includes
+ oe_libinstall -a -so libart_lgpl_2 ${STAGING_LIBDIR}
+}