summaryrefslogtreecommitdiff
path: root/packages/gnome/gnome-python-extras_2.19.1.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-09-03 15:04:08 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-09-03 15:04:08 +0000
commit77fe2053f54d554884e65c6e4336f014f7f80fe0 (patch)
tree81a2dc40d2ef4faf0c2a3a7aef62eba41bad1cff /packages/gnome/gnome-python-extras_2.19.1.bb
parentae80bc3aada834677e6e0a1f6713ebe850e7bee1 (diff)
parent9d854b894b8741e62ffa9504a6490abbff1b38b7 (diff)
merge of '23d1f770a092f023ba951e138b787c9bacc3152d'
and 'fe28a990b29bbfd099e38e4fe044896bd0a0d68e'
Diffstat (limited to 'packages/gnome/gnome-python-extras_2.19.1.bb')
-rw-r--r--packages/gnome/gnome-python-extras_2.19.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/gnome/gnome-python-extras_2.19.1.bb b/packages/gnome/gnome-python-extras_2.19.1.bb
new file mode 100644
index 0000000000..9d8e786241
--- /dev/null
+++ b/packages/gnome/gnome-python-extras_2.19.1.bb
@@ -0,0 +1,21 @@
+LICENSE = "GPL/LGPL"
+DEPENDS = "python-pygtk libwnck"
+
+inherit gnome distutils-base
+
+SRC_URI += "file://acinclude.m4"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+do_configure_prepend() {
+ sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g ${S}/configure.ac
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN}-dev += "${datadir}/pygtk"