summaryrefslogtreecommitdiff
path: root/packages/gnome/gconf-dbus_svn.bb
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2006-01-20 06:00:30 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-20 06:00:30 +0000
commit9993d1748f9ef5c52aa0d6e3d3e0295248b921c6 (patch)
treefa503878d712ef3f49aeff30de96a9141140f609 /packages/gnome/gconf-dbus_svn.bb
parent2dc9ee48f37e5ccbf2b7220911c270baa7bcd170 (diff)
gconf-dbus: fix compile error with gconf lock functions in XML backend and fix oldxml in Makefile
Diffstat (limited to 'packages/gnome/gconf-dbus_svn.bb')
-rw-r--r--packages/gnome/gconf-dbus_svn.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/packages/gnome/gconf-dbus_svn.bb b/packages/gnome/gconf-dbus_svn.bb
index 194ca00263..39437ac33f 100644
--- a/packages/gnome/gconf-dbus_svn.bb
+++ b/packages/gnome/gconf-dbus_svn.bb
@@ -12,6 +12,8 @@ PR = "r0"
SRC_URI = "svn://developer.imendio.com/svn/gconf-dbus;module=trunk;proto=http \
file://gconf-dbus-update.patch;patch=1;pnum=0 \
+ file://xml-backend-locks-compile-fix.patch;patch=1 \
+ file://xml-backend-oldxml-Makefile.patch \
file://69gconfd-dbus"
inherit pkgconfig autotools
@@ -23,6 +25,11 @@ EXTRA_OECONF = " --with-ipc=dbus --disable-gtk-doc --enable-gtk --host=${HOST_SY
HEADERS = "gconf.h gconf-changeset.h gconf-listeners.h gconf-schema.h gconf-value.h gconf-error.h gconf-engine.h gconf-client.h gconf-enum-types.h"
+do_compile_prepend() {
+ cd ${S}
+ patch -p1 < ../xml-backend-oldxml-Makefile.patch
+}
+
do_stage() {
oe_libinstall -so -C gconf libgconf-2 ${STAGING_LIBDIR}
install -d ${STAGING_INCDIR}/gconf/2/gconf/