summaryrefslogtreecommitdiff
path: root/packages/gmp/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/gmp/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/gmp/files')
-rw-r--r--packages/gmp/files/sh4-asmfix.patch26
-rw-r--r--packages/gmp/files/x86-fat.diff122
2 files changed, 0 insertions, 148 deletions
diff --git a/packages/gmp/files/sh4-asmfix.patch b/packages/gmp/files/sh4-asmfix.patch
deleted file mode 100644
index 1a01f61533..0000000000
--- a/packages/gmp/files/sh4-asmfix.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- gmp-4.1.4/mpn/sh/add_n.s 2005/11/17 08:44:00 1.1
-+++ gmp-4.1.4/mpn/sh/add_n.s 2005/11/17 08:18:57
-@@ -29,8 +29,8 @@
-
- .text
- .align 2
-- .global ___gmpn_add_n
--___gmpn_add_n:
-+ .global __gmpn_add_n
-+__gmpn_add_n:
- mov #0,r3 ! clear cy save reg
-
- Loop: mov.l @r5+,r1
---- gmp-4.1.4/mpn/sh/sub_n.s 2005/11/17 08:44:04 1.1
-+++ gmp-4.1.4/mpn/sh/sub_n.s 2005/11/17 08:18:59
-@@ -29,8 +29,8 @@
-
- .text
- .align 2
-- .global ___gmpn_sub_n
--___gmpn_sub_n:
-+ .global __gmpn_sub_n
-+__gmpn_sub_n:
- mov #0,r3 ! clear cy save reg
-
- Loop: mov.l @r5+,r1
diff --git a/packages/gmp/files/x86-fat.diff b/packages/gmp/files/x86-fat.diff
deleted file mode 100644
index 2a54622a26..0000000000
--- a/packages/gmp/files/x86-fat.diff
+++ /dev/null
@@ -1,122 +0,0 @@
-See:
-
- http://gmplib.org/patches/x86-fat.diff
- http://gmplib.org/list-archives/gmp-bugs/2006-October/000579.html
- http://gmplib.org/#BUGREPORTS
-
-Removed the configure part of the patch since we patch configure.in. It was
-only needed for FAT binaries anyway and this is being included to fix
-linking errors.
-
-Index: mpn/generic/addsub_n.c
-===================================================================
-RCS file: /home/cvsfiles/gmp42/mpn/generic/addsub_n.c,v
-retrieving revision 1.1
-retrieving revision 1.2
-diff -p -2 -r1.1 -r1.2
-*** mpn/generic/addsub_n.c 14 Mar 2006 15:57:54 -0000 1.1
---- mpn/generic/addsub_n.c 15 May 2006 22:38:42 -0000 1.2
-***************
-*** 1,5 ****
- /* mpn_addsub_n -- Add and Subtract two limb vectors of equal, non-zero length.
-
-! Copyright 1999, 2000, 2001 Free Software Foundation, Inc.
-
- This file is part of the GNU MP Library.
---- 1,5 ----
- /* mpn_addsub_n -- Add and Subtract two limb vectors of equal, non-zero length.
-
-! Copyright 1999, 2000, 2001, 2006 Free Software Foundation, Inc.
-
- This file is part of the GNU MP Library.
-*************** mpn_addsub_n (mp_ptr r1p, mp_ptr r2p, mp
-*** 59,63 ****
- {
- this_n = MIN (n - off, PART_SIZE);
-! #if HAVE_NATIVE_mpn_add_nc || !HAVE_NATIVE_mpn_add_n
- acyo = mpn_add_nc (r1p + off, s1p + off, s2p + off, this_n, acyo);
- #else
---- 59,63 ----
- {
- this_n = MIN (n - off, PART_SIZE);
-! #if HAVE_NATIVE_mpn_add_nc
- acyo = mpn_add_nc (r1p + off, s1p + off, s2p + off, this_n, acyo);
- #else
-*************** mpn_addsub_n (mp_ptr r1p, mp_ptr r2p, mp
-*** 65,69 ****
- acyo = acyn + mpn_add_1 (r1p + off, r1p + off, this_n, acyo);
- #endif
-! #if HAVE_NATIVE_mpn_sub_nc || !HAVE_NATIVE_mpn_sub_n
- scyo = mpn_sub_nc (r2p + off, s1p + off, s2p + off, this_n, scyo);
- #else
---- 65,69 ----
- acyo = acyn + mpn_add_1 (r1p + off, r1p + off, this_n, acyo);
- #endif
-! #if HAVE_NATIVE_mpn_sub_nc
- scyo = mpn_sub_nc (r2p + off, s1p + off, s2p + off, this_n, scyo);
- #else
-*************** mpn_addsub_n (mp_ptr r1p, mp_ptr r2p, mp
-*** 82,86 ****
- {
- this_n = MIN (n - off, PART_SIZE);
-! #if HAVE_NATIVE_mpn_sub_nc || !HAVE_NATIVE_mpn_sub_n
- scyo = mpn_sub_nc (r2p + off, s1p + off, s2p + off, this_n, scyo);
- #else
---- 82,86 ----
- {
- this_n = MIN (n - off, PART_SIZE);
-! #if HAVE_NATIVE_mpn_sub_nc
- scyo = mpn_sub_nc (r2p + off, s1p + off, s2p + off, this_n, scyo);
- #else
-*************** mpn_addsub_n (mp_ptr r1p, mp_ptr r2p, mp
-*** 88,92 ****
- scyo = scyn + mpn_sub_1 (r2p + off, r2p + off, this_n, scyo);
- #endif
-! #if HAVE_NATIVE_mpn_add_nc || !HAVE_NATIVE_mpn_add_n
- acyo = mpn_add_nc (r1p + off, s1p + off, s2p + off, this_n, acyo);
- #else
---- 88,92 ----
- scyo = scyn + mpn_sub_1 (r2p + off, r2p + off, this_n, scyo);
- #endif
-! #if HAVE_NATIVE_mpn_add_nc
- acyo = mpn_add_nc (r1p + off, s1p + off, s2p + off, this_n, acyo);
- #else
-*************** mpn_addsub_n (mp_ptr r1p, mp_ptr r2p, mp
-*** 98,102 ****
- else
- {
-! /* r1 and r2 are identical to s1 and s2 (r1==s1 and r2=s2 or vice versa)
- Need temporary storage. */
- mp_limb_t tp[PART_SIZE];
---- 98,102 ----
- else
- {
-! /* r1 and r2 are identical to s1 and s2 (r1==s1 and r2==s2 or vice versa)
- Need temporary storage. */
- mp_limb_t tp[PART_SIZE];
-*************** mpn_addsub_n (mp_ptr r1p, mp_ptr r2p, mp
-*** 106,110 ****
- {
- this_n = MIN (n - off, PART_SIZE);
-! #if HAVE_NATIVE_mpn_add_nc || !HAVE_NATIVE_mpn_add_n
- acyo = mpn_add_nc (tp, s1p + off, s2p + off, this_n, acyo);
- #else
---- 106,110 ----
- {
- this_n = MIN (n - off, PART_SIZE);
-! #if HAVE_NATIVE_mpn_add_nc
- acyo = mpn_add_nc (tp, s1p + off, s2p + off, this_n, acyo);
- #else
-*************** mpn_addsub_n (mp_ptr r1p, mp_ptr r2p, mp
-*** 112,116 ****
- acyo = acyn + mpn_add_1 (tp, tp, this_n, acyo);
- #endif
-! #if HAVE_NATIVE_mpn_sub_nc || !HAVE_NATIVE_mpn_sub_n
- scyo = mpn_sub_nc (r2p + off, s1p + off, s2p + off, this_n, scyo);
- #else
---- 112,116 ----
- acyo = acyn + mpn_add_1 (tp, tp, this_n, acyo);
- #endif
-! #if HAVE_NATIVE_mpn_sub_nc
- scyo = mpn_sub_nc (r2p + off, s1p + off, s2p + off, this_n, scyo);
- #else