summaryrefslogtreecommitdiff
path: root/packages/glibc/glibc-initial_2.2.5.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-18 01:01:16 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-18 01:01:16 +0000
commit2650645237555cc24c532a4c9ccd81d8c01bcaf7 (patch)
tree297cb8213bb881f96893b6246a623718af50a8e1 /packages/glibc/glibc-initial_2.2.5.bb
parent6e012296c2dc513ae301654b3d4d3eb826068c81 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/17 19:01:15-06:00 ti.com!kergoth Move 'patcher-native' into a PATCH_DEPENDS variable. 2005/01/17 18:35:01-06:00 ti.com!kergoth Teach base_do_patch to unapply all the patches before it starts applying things. This ensures that a patch being 'already applied' isn't a problem. BKrev: 41ec5fdcZyPXKe57f5FM3PpA19zcww
Diffstat (limited to 'packages/glibc/glibc-initial_2.2.5.bb')
-rw-r--r--packages/glibc/glibc-initial_2.2.5.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/packages/glibc/glibc-initial_2.2.5.bb b/packages/glibc/glibc-initial_2.2.5.bb
index e69de29bb2..4e7ad73191 100644
--- a/packages/glibc/glibc-initial_2.2.5.bb
+++ b/packages/glibc/glibc-initial_2.2.5.bb
@@ -0,0 +1,46 @@
+SECTION = "libs"
+include glibc_${PV}.bb
+
+DEPENDS = "linux-libc-headers"
+PROVIDES = "virtual/${TARGET_PREFIX}libc-initial"
+FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/glibc-${PV}', '${FILE_DIRNAME}/glibc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
+
+PACKAGES = ""
+
+do_configure () {
+ sed -ie 's,{ (exit 1); exit 1; }; },{ (exit 0); }; },g' ${S}/configure
+ chmod +x ${S}/configure
+ CC="${BUILD_CC}" CPP="${BUILD_CPP}" LD="${BUILD_LD}" ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \
+ --without-cvs --disable-sanity-checks \
+ --with-headers=${CROSS_DIR}/${TARGET_SYS}/include \
+ --enable-hacker-mode
+ if grep -q GLIBC_2.3 ${S}/ChangeLog; then
+ # glibc-2.3.x passes cross options to $(CC) when generating errlist-compat.c, which fails without a real cross-compiler.
+ # Fortunately, we don't need errlist-compat.c, since we just need .h files,
+ # so work around this by creating a fake errlist-compat.c and satisfying its dependencies.
+ # Another workaround might be to tell configure to not use any cross options to $(CC).
+ # The real fix would be to get install-headers to not generate errlist-compat.c.
+ make sysdeps/gnu/errlist.c
+ mkdir -p stdio-common
+ touch stdio-common/errlist-compat.c
+ fi
+}
+
+do_compile () {
+ :
+}
+
+do_stage () {
+ oe_runmake cross-compiling=yes install_root=${CROSS_DIR}/${TARGET_SYS} prefix="" install-headers
+
+ # Two headers -- stubs.h and features.h -- aren't installed by install-headers,
+ # so do them by hand. We can tolerate an empty stubs.h for the moment.
+ # See e.g. http://gcc.gnu.org/ml/gcc/2002-01/msg00900.html
+ mkdir -p ${CROSS_DIR}/${TARGET_SYS}/include/gnu
+ touch ${CROSS_DIR}/${TARGET_SYS}/include/gnu/stubs.h
+ cp ${S}/include/features.h ${CROSS_DIR}/${TARGET_SYS}/include/features.h
+}
+
+do_install () {
+ :
+}