summaryrefslogtreecommitdiff
path: root/packages/glibc/glibc-2.4/glibc-use-isystem-include-fixed.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2008-09-13 01:47:08 +0000
committerKhem Raj <raj.khem@gmail.com>2008-09-13 01:47:08 +0000
commit2da8451745e6168f888392698258ff8fa1e94f76 (patch)
tree2e97ac853ca5effb827096b85e246b4abf1f7a5f /packages/glibc/glibc-2.4/glibc-use-isystem-include-fixed.patch
parent52de0e7dc7de57f7ac24fdc645a8eb464e224fb1 (diff)
This fixes the problem reported in bug 4536. Backport the patch which adds include-fixed to be searched for include files in glibc configure mechanism. This means we do not need the include packaging hack that we have in gcc 4.3.x recipes.
I was using 2.6.25 kernel headers which means I have to backport another patch to get rid of asm/page.h. I have tested it on angstrom 2008.1 gcc-4.3.2+glibc-2.6.1 and gcc-4.3.2+eglibc_svn -Khem
Diffstat (limited to 'packages/glibc/glibc-2.4/glibc-use-isystem-include-fixed.patch')
-rw-r--r--packages/glibc/glibc-2.4/glibc-use-isystem-include-fixed.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/packages/glibc/glibc-2.4/glibc-use-isystem-include-fixed.patch b/packages/glibc/glibc-2.4/glibc-use-isystem-include-fixed.patch
new file mode 100644
index 0000000000..d9ed12a0fe
--- /dev/null
+++ b/packages/glibc/glibc-2.4/glibc-use-isystem-include-fixed.patch
@@ -0,0 +1,46 @@
+http://sourceware.org/ml/libc-alpha/2007-03/msg00017.html
+
+GCC trunk now has multiple internal headers directories, one
+containing the self-contained GCC-provided headers and one containing
+the <limits.h> (not self-contained but including libc's <limits.h> or
+a fixed version thereof) and the fixed headers; more such directories
+may be added in future.
+
+When glibc uses -nostdinc, it needs to use -isystem options for all
+these internal directories. This patch teaches it about the
+include-fixed directory (and is harmless with old GCC versions without
+that directory).
+
+2007-03-18 Joseph Myers <joseph@codesourcery.com>
+
+ * configure.in: Also pass -isystem option for GCC's include-fixed
+ directory.
+ * configure: Regenerate.
+
+
+Index: glibc-2.6.1/configure
+===================================================================
+--- glibc-2.6.1.orig/configure 2008-09-12 16:38:06.000000000 -0700
++++ glibc-2.6.1/configure 2008-09-12 16:39:22.000000000 -0700
+@@ -4563,7 +4563,7 @@
+ # thing on a system that doesn't need fixincludes. (Not presently a problem.)
+ if test -n "$sysheaders"; then
+ ccheaders=`$CC -print-file-name=include`
+- SYSINCLUDES="-nostdinc -isystem $ccheaders \
++ SYSINCLUDES="-nostdinc -isystem $ccheaders -isystem $ccheaders-fixed \
+ -isystem `echo $sysheaders | sed 's/:/ -isystem /g'`"
+ if test -n "$CXX"; then
+ cxxversion=`$CXX -dumpversion 2>&5` &&
+Index: glibc-2.6.1/configure.in
+===================================================================
+--- glibc-2.6.1.orig/configure.in 2008-09-12 16:38:26.000000000 -0700
++++ glibc-2.6.1/configure.in 2008-09-12 16:39:01.000000000 -0700
+@@ -912,7 +912,7 @@
+ # thing on a system that doesn't need fixincludes. (Not presently a problem.)
+ if test -n "$sysheaders"; then
+ ccheaders=`$CC -print-file-name=include`
+- SYSINCLUDES="-nostdinc -isystem $ccheaders \
++ SYSINCLUDES="-nostdinc -isystem $ccheaders -isystem $ccheaders-fixed \
+ -isystem `echo $sysheaders | sed 's/:/ -isystem /g'`"
+ if test -n "$CXX"; then
+ cxxversion=`$CXX -dumpversion 2>&AS_MESSAGE_LOG_FD` &&