summaryrefslogtreecommitdiff
path: root/packages/glibc/files/ppc-ports-ld-nofpu-20070114.patch
diff options
context:
space:
mode:
authorStelios Koroneos <skoroneos@digital-opsis.com>2007-03-12 12:50:09 +0000
committerStelios Koroneos <skoroneos@digital-opsis.com>2007-03-12 12:50:09 +0000
commit97f6ae6dc70d325762bfb84c3a1770fe2ea74022 (patch)
treeda16383c74931de18bd759f4e52032c23d0eb5ae /packages/glibc/files/ppc-ports-ld-nofpu-20070114.patch
parent242ff6b8bc003c6529e9e50af75294ba4b862906 (diff)
packages/glibc/glibc_2.5.bb: The following set of patches adds support for soft-float to powerpc targets
without fpu for gcc 4.1.1/glibc 2.5
Diffstat (limited to 'packages/glibc/files/ppc-ports-ld-nofpu-20070114.patch')
-rw-r--r--packages/glibc/files/ppc-ports-ld-nofpu-20070114.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/glibc/files/ppc-ports-ld-nofpu-20070114.patch b/packages/glibc/files/ppc-ports-ld-nofpu-20070114.patch
new file mode 100644
index 0000000000..b4d99592f6
--- /dev/null
+++ b/packages/glibc/files/ppc-ports-ld-nofpu-20070114.patch
@@ -0,0 +1,38 @@
+2007-01-14 Steven Munroe <sjmunroe@us.ibm.com>
+
+ [BZ #2749]
+ * sysdeps/powerpc/nofpu/fenv_libc.h: New file.
+
+diff -urN dummy-libc/ports-cvstip-20070104/sysdeps/powerpc/nofpu/fenv_libc.h libc25/ports/sysdeps/powerpc/nofpu/fenv_libc.h
+--- dummy-libc/ports-cvstip-20070104/sysdeps/powerpc/nofpu/fenv_libc.h Wed Dec 31 18:00:00 1969
++++ libc25/ports/sysdeps/powerpc/nofpu/fenv_libc.h Thu Jan 11 11:00:53 2007
+@@ -0,0 +1,29 @@
++/* Internal libc stuff for floating point environment routines.
++ Copyright (C) 2007 Free Software Foundation, Inc.
++ This file is part of the GNU C Library.
++
++ The GNU C Library is free software; you can redistribute it and/or
++ modify it under the terms of the GNU Lesser General Public
++ License as published by the Free Software Foundation; either
++ version 2.1 of the License, or (at your option) any later version.
++
++ The GNU C Library is distributed in the hope that it will be useful,
++ but WITHOUT ANY WARRANTY; without even the implied warranty of
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ Lesser General Public License for more details.
++
++ You should have received a copy of the GNU Lesser General Public
++ License along with the GNU C Library; if not, write to the Free
++ Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
++ 02111-1307 USA. */
++
++#ifndef _FENV_LIBC_H
++#define _FENV_LIBC_H 1
++
++/* fenv_libc.h is used in libm implementations of ldbl-128ibm. So we
++ need this version in the soft-fp to at minimum include fenv.h to
++ get the fegetround definition. */
++
++#include <fenv.h>
++
++#endif /* fenv_libc.h */