summaryrefslogtreecommitdiff
path: root/packages/gizmod/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/gizmod/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/gizmod/files')
-rw-r--r--packages/gizmod/files/3.4-build-fix.patch71
-rw-r--r--packages/gizmod/files/disable-bmp.patch105
-rw-r--r--packages/gizmod/files/disable-xmms.patch113
-rw-r--r--packages/gizmod/files/fix-python-configure.patch17
4 files changed, 0 insertions, 306 deletions
diff --git a/packages/gizmod/files/3.4-build-fix.patch b/packages/gizmod/files/3.4-build-fix.patch
deleted file mode 100644
index d0a11da62b..0000000000
--- a/packages/gizmod/files/3.4-build-fix.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-Index: gizmod-3.4/cmake/Modules/DefineCompilerFlags.cmake
-===================================================================
---- gizmod-3.4.orig/cmake/Modules/DefineCompilerFlags.cmake
-+++ gizmod-3.4/cmake/Modules/DefineCompilerFlags.cmake
-@@ -15,4 +15,4 @@ if (UNIX AND NOT WIN32)
- #endif (CMAKE_SIZEOF_VOID_P MATCHES "8")
- endif (UNIX AND NOT WIN32)
-
--add_definitions(-DHAVE_CONFIG_H -Wall -Werror)
-+add_definitions(-DHAVE_CONFIG_H)
-Index: gizmod-3.4/libGizmod/Alsa.cpp
-===================================================================
---- gizmod-3.4.orig/libGizmod/Alsa.cpp
-+++ gizmod-3.4/libGizmod/Alsa.cpp
-@@ -149,10 +149,11 @@ void Alsa::onAlsaEventMixerElementAttach
- **/
- void Alsa::onAlsaEventMixerElementChange(AlsaEvent const & Event, AlsaSoundCard const & SoundCard, AlsaMixer const & Mixer) {
- // override me
-- if (Event.Type == ALSAEVENT_MIXERELEMENT_CHANGE)
-+ if (Event.Type == ALSAEVENT_MIXERELEMENT_CHANGE) {
- cdbg2 << "Mixer Element Changed [" << Mixer.getName() << "] with Mask [" << stringconverter(Event.IsActiveChanged) << stringconverter(Event.ElementsChanged) << stringconverter(Event.VolumePlaybackChanged) << "] on Sound Card [" << SoundCard.getCardName() << "] " << Mixer.VolumePlaybackPercent << endl;
-- else
-+ } else {
- cdbg2 << "Mixer Element Changed [" << Mixer.getName() << "] with Mask [" << stringconverter(Event.Mask) << "] on Sound Card [" << SoundCard.getCardName() << "]" << endl;
-+ }
- }
-
- /**
-Index: gizmod-3.4/libGizmod/GizmoLinuxInputEvent.hpp
-===================================================================
---- gizmod-3.4.orig/libGizmod/GizmoLinuxInputEvent.hpp
-+++ gizmod-3.4/libGizmod/GizmoLinuxInputEvent.hpp
-@@ -54,7 +54,7 @@ namespace Gizmod {
- * \struct GizmoTimeVal
- * \brief Wrapper for the C timeval struct (for exposure to Python)
- **/
--typedef struct GizmoTimeVal {
-+struct GizmoTimeVal {
- unsigned int Seconds; ///< Time in Seconds
- unsigned int MicroSeconds; ///< Time remaining (after Seconds) in MicroSeconds
-
-Index: gizmod-3.4/libH/FileEventWatcher.cpp
-===================================================================
---- gizmod-3.4.orig/libH/FileEventWatcher.cpp
-+++ gizmod-3.4/libH/FileEventWatcher.cpp
-@@ -453,11 +453,12 @@ void FileEventWatcher::handleEventsOnFil
- // read from the inotify device
- char ReadBuffer[NOTIFY_READ_BUF_SIZE];
- int BytesRead = read(mInotifyFD, ReadBuffer, NOTIFY_READ_BUF_SIZE);
-- if (BytesRead < 0)
-+ if (BytesRead < 0) {
- if (errno == EINTR)
- return;
- else
- throw H::Exception("Failed to Read from Inotify Device!", __FILE__, __FUNCTION__, __LINE__);
-+ }
-
- // loop through all of the returned inotify_event structures and produce events
- int BytesHandled = 0;
-Index: gizmod-3.4/libH/Util.hpp
-===================================================================
---- gizmod-3.4.orig/libH/Util.hpp
-+++ gizmod-3.4/libH/Util.hpp
-@@ -36,6 +36,7 @@
- #include "Debug.hpp"
- #include <cstdlib>
- #include <iostream>
-+#include <algorithm>
-
- //////////////////////////////////////////////////////////////////////////////
- // Namespace
diff --git a/packages/gizmod/files/disable-bmp.patch b/packages/gizmod/files/disable-bmp.patch
deleted file mode 100644
index 89dfad3446..0000000000
--- a/packages/gizmod/files/disable-bmp.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-Index: gizmod-2.3/configure.ac
-===================================================================
---- gizmod-2.3.orig/configure.ac
-+++ gizmod-2.3/configure.ac
-@@ -319,76 +319,6 @@ fi
-
- ###########################################################################
- ##
--## Check whether to build BMP plugin
--##
--
--##################
--## enabled?
--########
--
--AC_MSG_CHECKING(Whether or not to build BMP plugin)
--AC_ARG_ENABLE(bmp,
-- [ --enable-bmp build BMP plugin <default = no>],
-- [enable_bmp="$enableval"], enable_bmp=no)
--AC_MSG_RESULT($enable_bmp)
--
--AM_CONDITIONAL(BUILD_EXTERNALPLUGIN_BMP, test x$enable_bmp = xyes)
--AM_CONDITIONAL(BUILD_PLUGIN_BMPCONTROL, test x$enable_bmp = xyes)
--
--##################
--## can we build it if it's enabled?
--########
--
--if test "$enable_bmp" == "yes"; then
--
--BEEP_CFLAGS=""
--BEEP_LIBS=""
--
--#check stuff
--AM_PATH_GLIB_2_0(2.4.0, ,
-- AC_MSG_ERROR([GTK+ >= 2.4.0 not installed - required for BMP plugin]))
--AM_PATH_GTK_2_0(2.4.0, ,
-- AC_MSG_ERROR([GTK+ >= 2.4.0 not installed - required for BMP plugin]))
--
--dnl check for beep
--PKG_CHECK_MODULES(BEEP, [ bmp >= 0.9.7], ,
-- AC_MSG_ERROR("You need the BEEP development files to build the BEEP plugin!"))
--
--BEEP_PLUGIN_DIR="`$PKG_CONFIG --variable=output_plugin_dir bmp`"
--BEEP_INPUT_PLUGIN_DIR="`$PKG_CONFIG --variable=input_plugin_dir bmp`"
--BEEP_OUTPUT_PLUGIN_DIR="`$PKG_CONFIG --variable=output_plugin_dir bmp`"
--BEEP_GENERAL_PLUGIN_DIR="`$PKG_CONFIG --variable=general_plugin_dir bmp`"
--BEEP_VISUALIZATION_PLUGIN_DIR="`$PKG_CONFIG --variable=visualization_plugin_dir bmp`"
--BEEP_EFFECT_PLUGIN_DIR="`$PKG_CONFIG --variable=effect_plugin_dir bmp`"
--BEEP_DATA_DIR="`$PKG_CONFIG --variable=data_dir bmp`"
--
--AC_SUBST(BEEP_PLUGIN_DIR)
--AC_SUBST(BEEP_INPUT_PLUGIN_DIR)
--AC_SUBST(BEEP_OUTPUT_PLUGIN_DIR)
--AC_SUBST(BEEP_GENERAL_PLUGIN_DIR)
--AC_SUBST(BEEP_VISUALIZATION_PLUGIN_DIR)
--AC_SUBST(BEEP_EFFECT_PLUGIN_DIR)
--AC_SUBST(BEEP_DATA_DIR)
--
--dnl make BEEP_DATA_DIR a variable in config.h
--AH_TEMPLATE(BEEP_DATA_DIR, "Path to bmp-touch.config")
--AC_DEFINE_UNQUOTED(BEEP_DATA_DIR, "$BEEP_DATA_DIR")
--
--CPPFLAGS="$CPPFLAGS $BEEP_CFLAGS"
--
--AC_CHECK_HEADER(bmp/beepctrl.h, [
-- AC_DEFINE(HAVE_BEEPCTRL_H, 1, [Has bmp/beepctrl.h])
-- ], [
-- AC_MSG_ERROR([Cannot find beepctrl.h!])
-- ])
--
--AC_SUBST(BEEP_CFLAGS)
--AC_SUBST(BEEP_LIBS)
--
--fi
--
--###########################################################################
--##
- ## Check whether to build Sound Visualization plugin
- ##
-
-@@ -633,9 +563,7 @@ AC_CONFIG_FILES([
- plugins/soundVisualization/Makefile
- plugins/cpuUsage/Makefile
- plugins/x11/Makefile
-- plugins/bmpControl/Makefile
- plugins/externalPlugins/Makefile
-- plugins/externalPlugins/bmp/Makefile
- plugins/lirc/Makefile
- ])
- AC_OUTPUT
-Index: gizmod-2.3/plugins/Makefile.am
-===================================================================
---- gizmod-2.3.orig/plugins/Makefile.am
-+++ gizmod-2.3/plugins/Makefile.am
-@@ -1 +1 @@
--SUBDIRS=scriptingPlugins powermate alsaMixer xosd generic externalPlugins soundVisualization cpuUsage x11 bmpControl lirc
-+SUBDIRS=scriptingPlugins powermate alsaMixer xosd generic externalPlugins soundVisualization cpuUsage x11 lirc
-Index: gizmod-2.3/plugins/externalPlugins/Makefile.am
-===================================================================
---- gizmod-2.3.orig/plugins/externalPlugins/Makefile.am
-+++ gizmod-2.3/plugins/externalPlugins/Makefile.am
-@@ -1 +1 @@
--SUBDIRS=bmp
-+SUBDIRS=
diff --git a/packages/gizmod/files/disable-xmms.patch b/packages/gizmod/files/disable-xmms.patch
deleted file mode 100644
index e8aea12b4c..0000000000
--- a/packages/gizmod/files/disable-xmms.patch
+++ /dev/null
@@ -1,113 +0,0 @@
-Index: gizmod-2.3/configure.ac
-===================================================================
---- gizmod-2.3.orig/configure.ac
-+++ gizmod-2.3/configure.ac
-@@ -393,60 +393,6 @@ fi
-
- ###########################################################################
- ##
--## Check whether to build XMMS plugin
--##
--
--##################
--## enabled?
--########
--
--AC_MSG_CHECKING(Whether or not to build XMMS plugin)
--AC_ARG_ENABLE(xmms,
-- [ --enable-xmms build XMMS plugin <default = yes>],
-- [enable_xmms="$enableval"], enable_xmms=yes)
--AC_MSG_RESULT($enable_xmms)
--
--AM_CONDITIONAL(BUILD_EXTERNALPLUGIN_XMMS, test x$enable_xmms = xyes)
--AM_CONDITIONAL(BUILD_PLUGIN_XMMSCONTROL, test x$enable_xmms = xyes)
--
--##################
--## can we build it if it's enabled?
--########
--
--if test "$enable_xmms" == "yes"; then
--
--XMMS_CFLAGS=""
--XMMS_LIBS=""
--
--#check stuff
--
--AM_PATH_XMMS(1.2.4,
-- XMMS_CFLAGS=`xmms-config --cflags`
-- CPPFLAGS="$CPPFLAGS $XMMS_CFLAGS"
-- XMMS_LIBS=`xmms-config --libs`
-- ,
-- AC_MSG_ERROR([You must have the XMMS development headers installed to build the XMMS plugin!])
--)
--
--AC_CHECK_HEADER(xmms/xmmsctrl.h, [
-- AC_DEFINE(HAVE_XMMSCTRL_H, 1, [Has xmms/xmmsctrl.h])
-- ], [
-- AC_MSG_ERROR([Cannot find xmmsctrl.h!])
-- ])
--
--AC_CHECK_HEADER(xmms/plugin.h, [
-- AC_DEFINE(HAVE_XMMSPLUGIN_H, 1, [Has xmms/xmmsplugin.h])
-- ], [
-- AC_MSG_ERROR([Cannot find xmms/plugin.h!])
-- ])
--
--AC_SUBST(XMMS_CFLAGS)
--AC_SUBST(XMMS_LIBS)
--
--fi
--
--###########################################################################
--##
- ## Check whether to build Sound Visualization plugin
- ##
-
-@@ -691,10 +637,8 @@ AC_CONFIG_FILES([
- plugins/soundVisualization/Makefile
- plugins/cpuUsage/Makefile
- plugins/x11/Makefile
-- plugins/xmmsControl/Makefile
- plugins/bmpControl/Makefile
- plugins/externalPlugins/Makefile
-- plugins/externalPlugins/xmms/Makefile
- plugins/externalPlugins/bmp/Makefile
- plugins/lirc/Makefile
- ])
-@@ -774,22 +718,10 @@ else
- echo " BMP Control plugin: Disabled"
- fi
-
--if test "$enable_xmms" == "yes"; then
-- echo " XMMS Control plugin: Enabled"
--else
-- echo " XMMS Control plugin: Disabled"
--fi
--
- if test "$enable_bmp" == "yes"; then
- echo " BMP Visualization plugin: Enabled"
- else
- echo " BMP Visualization plugin: Disabled"
- fi
-
--if test "$enable_xmms" == "yes"; then
-- echo " XMMS Visualization plugin: Enabled"
--else
-- echo " XMMS Visualization plugin: Disabled"
--fi
--
- echo
-Index: gizmod-2.3/plugins/Makefile.am
-===================================================================
---- gizmod-2.3.orig/plugins/Makefile.am
-+++ gizmod-2.3/plugins/Makefile.am
-@@ -1 +1 @@
--SUBDIRS=scriptingPlugins powermate alsaMixer xosd generic externalPlugins soundVisualization cpuUsage x11 xmmsControl bmpControl lirc
-+SUBDIRS=scriptingPlugins powermate alsaMixer xosd generic externalPlugins soundVisualization cpuUsage x11 bmpControl lirc
-Index: gizmod-2.3/plugins/externalPlugins/Makefile.am
-===================================================================
---- gizmod-2.3.orig/plugins/externalPlugins/Makefile.am
-+++ gizmod-2.3/plugins/externalPlugins/Makefile.am
-@@ -1 +1 @@
--SUBDIRS=xmms bmp
-+SUBDIRS=bmp
diff --git a/packages/gizmod/files/fix-python-configure.patch b/packages/gizmod/files/fix-python-configure.patch
deleted file mode 100644
index 9b48c9790f..0000000000
--- a/packages/gizmod/files/fix-python-configure.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Index: gizmod-2.3/configure.ac
-===================================================================
---- gizmod-2.3.orig/configure.ac
-+++ gizmod-2.3/configure.ac
-@@ -162,11 +162,7 @@ CFLAGS="$PYTHON_INC $CFLAGS"
- # AC_MSG_ERROR([Cannot find python.h!])
- # ])
-
--AC_CHECK_FILE(${py_prefix}/include/python${py_ver}/Python.h, [
-- AC_DEFINE(HAVE_PYTHON_H, 1, [Has Python.h])
-- ], [
-- AC_MSG_ERROR([Cannot find Python.h!])
-- ])
-+AC_DEFINE(HAVE_PYTHON_H, 1, [Has Python.h])
-
- CFLAGS="$OLD_CFLAGS"
-