summaryrefslogtreecommitdiff
path: root/packages/git/git.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2005-09-13 14:34:15 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-13 14:34:15 +0000
commitb592ec4ea4cb7b57edc8b9f2953a336209fde60c (patch)
tree22204fa08331dfab9dab31213db92c509c72976a /packages/git/git.bb
parentaeb5e8d2e0ca39cd27c88265fbb5edea501d1ec9 (diff)
git: Add git and git-native packages. git-native may need some addition dependencies (curl-native, openssl-native) - I'm not sure what the policy is on this. Adding them should be straight forward enough though.
Diffstat (limited to 'packages/git/git.bb')
-rw-r--r--packages/git/git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/git/git.bb b/packages/git/git.bb
new file mode 100644
index 0000000000..3a1228d621
--- /dev/null
+++ b/packages/git/git.bb
@@ -0,0 +1,21 @@
+SECTION = "console/utils"
+LICENSE = "GPL"
+DESCRIPTION = "The git revision control system used by the Linux kernel developers"
+DEPENDS = "openssl curl"
+MAINTAINER = "Richard Purdie <rpurdie@rpsys.net>"
+
+PKGDATE = "${@time.strftime('%Y-%m-%d',time.gmtime())}"
+
+SRC_URI = "http://www.codemonkey.org.uk/projects/git-snapshots/git/git-${PKGDATE}.tar.gz \
+ file://Makefile.patch;patch=1"
+
+S = "${WORKDIR}/git-snapshot-${DATE}"
+
+FILES_${PN} += "${datadir}/git-core"
+
+do_install () {
+ oe_runmake install prefix=${D} bindir=${D}${bindir} \
+ template_dir=${D}${datadir}/git-core/templates \
+ GIT_PYTHON_DIR=${D}${datadir}/git-core/python
+}
+