summaryrefslogtreecommitdiff
path: root/packages/git/git-native.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2005-09-13 14:34:15 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-13 14:34:15 +0000
commitb592ec4ea4cb7b57edc8b9f2953a336209fde60c (patch)
tree22204fa08331dfab9dab31213db92c509c72976a /packages/git/git-native.bb
parentaeb5e8d2e0ca39cd27c88265fbb5edea501d1ec9 (diff)
git: Add git and git-native packages. git-native may need some addition dependencies (curl-native, openssl-native) - I'm not sure what the policy is on this. Adding them should be straight forward enough though.
Diffstat (limited to 'packages/git/git-native.bb')
-rw-r--r--packages/git/git-native.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/packages/git/git-native.bb b/packages/git/git-native.bb
new file mode 100644
index 0000000000..1bd495f085
--- /dev/null
+++ b/packages/git/git-native.bb
@@ -0,0 +1,8 @@
+include git.bb
+inherit native
+
+do_stage () {
+ oe_runmake install bindir=${STAGING_BINDIR} \
+ template_dir=${STAGING_DIR}/${BUILD_SYS}/share/git-core/templates/ \
+ GIT_PYTHON_DIR=${STAGING_DIR}/${BUILD_SYS}/share/git-core/python
+}