summaryrefslogtreecommitdiff
path: root/packages/gimp/gimp_2.2.10.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-04-06 22:39:32 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-06 22:39:32 +0000
commit6c97f56d28872da36cc0cc52631668985d8db22a (patch)
tree3957d53afc5c22540dedd5c61af13b28149a5b55 /packages/gimp/gimp_2.2.10.bb
parent3bcd16909c945940017ded43f94652f1a7acf2f5 (diff)
parent254167bc41a3aae1c45a5f769ec16dee2dd37e2e (diff)
merge of 5945a66a6847c21d25595376695c23f3971f6f8a
and e544df2d6779a2a53f1c47a6d1e1961d875d17af
Diffstat (limited to 'packages/gimp/gimp_2.2.10.bb')
-rw-r--r--packages/gimp/gimp_2.2.10.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/gimp/gimp_2.2.10.bb b/packages/gimp/gimp_2.2.10.bb
new file mode 100644
index 0000000000..59fb0a0467
--- /dev/null
+++ b/packages/gimp/gimp_2.2.10.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "The GIMP is the GNU Image Manipulation Program."
+HOMEPAGE = "http://www.gimp.org"
+LICENSE = "GPL"
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+
+SRC_URI = "ftp://ftp.gimp.org/pub/gimp/v2.2/gimp-${PV}.tar.bz2"
+
+DEPENDS = "gtk+ jpeg libpng libexif"
+
+inherit autotools pkgconfig
+#Don't laugh, this just builds a threaded gimp
+EXTRA_OECONF = " --disable-gtktest \
+ --without-libtiff \
+ --disable-print \
+ --enable-mp"
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+}
+