summaryrefslogtreecommitdiff
path: root/packages/gimp/gimp_2.2.10.bb
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2006-04-04 17:37:36 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-04 17:37:36 +0000
commita4472a7d1c2687e2dad791557ba3a63bcb7281ce (patch)
treeffb755994a8d75029fa755fd25796aab20f05196 /packages/gimp/gimp_2.2.10.bb
parentc121ca2c7e3e41472a4c4e2837cac69c76df5a53 (diff)
parent1e67ef797eb4c215540856dec5493e5a8c8dbb03 (diff)
merge of a7533fe1dde530db43cb0e31307632437139f2af
and d48f265f263a5f969f2abfd913a09b91a51a701f
Diffstat (limited to 'packages/gimp/gimp_2.2.10.bb')
-rw-r--r--packages/gimp/gimp_2.2.10.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/gimp/gimp_2.2.10.bb b/packages/gimp/gimp_2.2.10.bb
new file mode 100644
index 0000000000..59fb0a0467
--- /dev/null
+++ b/packages/gimp/gimp_2.2.10.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "The GIMP is the GNU Image Manipulation Program."
+HOMEPAGE = "http://www.gimp.org"
+LICENSE = "GPL"
+MAINTAINER = "Koen Kooi <koen@handhelds.org>"
+
+SRC_URI = "ftp://ftp.gimp.org/pub/gimp/v2.2/gimp-${PV}.tar.bz2"
+
+DEPENDS = "gtk+ jpeg libpng libexif"
+
+inherit autotools pkgconfig
+#Don't laugh, this just builds a threaded gimp
+EXTRA_OECONF = " --disable-gtktest \
+ --without-libtiff \
+ --disable-print \
+ --enable-mp"
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+}
+