summaryrefslogtreecommitdiff
path: root/packages/geoclue/geoclue_git.bb
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2007-06-22 17:57:39 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2007-06-22 17:57:39 +0000
commitb669962c250fb4a2a8c5badfe5b3717569b80abc (patch)
treeb75f8720b17f1fe93c76dc19407dc86cd73ad555 /packages/geoclue/geoclue_git.bb
parenta14b857a5eb21816991ca6ec50c9520f9bcc61dd (diff)
parent2f7f445a9c6463ce4a7cec1844911085b1536b1c (diff)
merge of 'a9d59f7c5db704e36d7f7dbda87b750cabbbc775'
and 'fcf3721db5cf2d3c669e8d3d36cd3ca4df792f6f'
Diffstat (limited to 'packages/geoclue/geoclue_git.bb')
-rw-r--r--packages/geoclue/geoclue_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/geoclue/geoclue_git.bb b/packages/geoclue/geoclue_git.bb
new file mode 100644
index 0000000000..6ae717e4b6
--- /dev/null
+++ b/packages/geoclue/geoclue_git.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "GeoClue is a project that provide all kinds of geography information to an application"
+HOMEPAGE = "http://live.gnome.org/GeoClue"
+
+DEPENDS = "gpsd ilibxml2 libsoup dbus-glib"
+
+PV = "0.0+git${SRCDATE}"
+PR = "r0"
+PE = "1"
+
+inherit autotools pkgconfig
+
+SRC_URI = "git://anongit.freedesktop.org/git/geoclue;protocol=git"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF = "--enable-panel-applet=no"
+
+do_install_append() {
+ mkdir -p ${D}/usr/share/
+ cp -pPr ${D}${STAGING_DATADIR}/* ${D}/usr/share
+ rm -rf ${D}${STAGING_DATADIR}/
+}
+
+PACKAGES =+ "geoclue-applet"
+
+FILES_geoclue-applet += " \
+ ${libdir}/bonobo/servers/* \
+ ${libdir}/gnome-panel/*"
+
+
+FILES_${PN} += " \
+ ${libdir}/gnome-panel/* \
+ ${datadir}/dbus-1"