summaryrefslogtreecommitdiff
path: root/packages/genlist/genlist.bb
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2005-11-27 22:37:11 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-27 22:37:11 +0000
commitb78a8c0c0d845cbebab4557122e104347ecb6b4b (patch)
tree2359fe9152adbc10e24e91074c49a92b02346350 /packages/genlist/genlist.bb
parent41cb1967e1acd8fd3e7d8642e814e9acae6d1aff (diff)
genlist: New package contributed by Bov Davies.
Diffstat (limited to 'packages/genlist/genlist.bb')
-rw-r--r--packages/genlist/genlist.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/genlist/genlist.bb b/packages/genlist/genlist.bb
new file mode 100644
index 0000000000..4fd6160cc2
--- /dev/null
+++ b/packages/genlist/genlist.bb
@@ -0,0 +1,20 @@
+SECTION = "utility"
+DESCRIPTION = "IP Address List Generator"
+MAINTAINER = "Bob Davies (tyggerbob@gmail.com)"
+
+SRC_URI = "file://genlist.c \
+ file://Makefile"
+
+DEFAULT_PREFERENCE="-1"
+
+
+S = "${WORKDIR}"
+LICENSE = "GPL"
+do_compile() {
+ oe_runmake all
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 genlist ${D}${bindir}/
+}