summaryrefslogtreecommitdiff
path: root/packages/gdb/gdb-cross_6.6.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-12-31 21:40:20 +0000
committerRichard Purdie <rpurdie@rpsys.net>2006-12-31 21:40:20 +0000
commit0c63af53e4cf85ec9a25436f7a21dea5b2b6f2d3 (patch)
tree8d7bfefaaf7c82fa540bc75b2ca121bbdda14eb4 /packages/gdb/gdb-cross_6.6.bb
parent2d4f22fd6cd0c8b75894d66f8eac3d075aede6dd (diff)
gdb: Add 6.6, drop 6.1, 6.2, 6.2.1. Make gdb RRECOMMEND the thread db package from glibc (gdb segfaults on arm EABI without it).
Diffstat (limited to 'packages/gdb/gdb-cross_6.6.bb')
-rw-r--r--packages/gdb/gdb-cross_6.6.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/gdb/gdb-cross_6.6.bb b/packages/gdb/gdb-cross_6.6.bb
new file mode 100644
index 0000000000..32076b529e
--- /dev/null
+++ b/packages/gdb/gdb-cross_6.6.bb
@@ -0,0 +1,35 @@
+LICENSE = "GPL"
+DESCRIPTION = "gdb - GNU debugger"
+SECTION = "base"
+PRIORITY = "optional"
+DEPENDS = "ncurses-native"
+
+inherit autotools sdk
+
+S = "${WORKDIR}/gdb-${PV}"
+SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
+ file://sim-install.patch;patch=1"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gdb-${PV}"
+
+export CC_FOR_BUILD = "${BUILD_CC}"
+export CXX_FOR_BUILD = "${BUILD_CXX}"
+export CPP_FOR_BUILD = "${BUILD_CPP}"
+export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
+export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
+export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
+
+EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils' LDFLAGS='${BUILD_LDFLAGS}'"
+
+EXTRA_OECONF = "--with-curses --with-readline"
+
+do_configure () {
+# override this function to avoid the autoconf/automake/aclocal/autoheader
+# calls for now
+ gnu-configize
+ oe_runconf
+}
+
+do_stage() {
+ :
+}