summaryrefslogtreecommitdiff
path: root/packages/gdal/gdal_1.3.2.bb
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2006-07-28 11:32:53 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2006-07-28 11:32:53 +0000
commit1287e38077fece73a2d0887c63bc869cf5c516c1 (patch)
tree6fdb2770b7b99b365c36ea40d9877ee17868f43e /packages/gdal/gdal_1.3.2.bb
parentf4008ca823bfbb7c33d92008137ff78cc6907f17 (diff)
parent39dba3e0ec9b72c5394d9ec669e68ecd87e23658 (diff)
merge of 23f392c4a32f829ba2c33998e47b14cc08c51a26
and a5ef4c4c70b547e6337fc06d8e0f67f7be568250
Diffstat (limited to 'packages/gdal/gdal_1.3.2.bb')
-rw-r--r--packages/gdal/gdal_1.3.2.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/gdal/gdal_1.3.2.bb b/packages/gdal/gdal_1.3.2.bb
new file mode 100644
index 0000000000..c445cd1274
--- /dev/null
+++ b/packages/gdal/gdal_1.3.2.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "GDAL is a translator library for raster geospatial data formats"
+HOMEPAGE = "http://www.gdal.org/"
+LICENSE = "MIT"
+DEPENDS = "zlib"
+
+SRC_URI = "http://www.gdal.org/dl/${P}.tar.gz"
+
+inherit autotools pkgconfig
+
+PARALLEL_MAKE = ""
+
+EXTRA_OECONF = "--without-perl \
+ --without-python \
+ --without-php \
+ --without-ruby \
+ --with-libz=internal \
+ --with-png=internal \
+ --with-jpeg=internal \
+ --with-libtiff=internal \
+ "
+
+do_configure_append() {
+ sed -i s:/usr/lib:${D}${libdir}: GDALmake.opt
+ sed -i s:/usr/bin:${D}${bindir}: GDALmake.opt
+ sed -i s:/usr/share:${D}${datadir}: GDALmake.opt
+ sed -i s:/usr/include:${D}${includedir}: GDALmake.opt
+}
+
+do_compile() {
+ oe_runmake default
+}
+
+
+do_package_prepend() {
+ # the brokenness....
+ os.system('cp -a ${D}${D}* ${D}../')
+}
+