summaryrefslogtreecommitdiff
path: root/packages/gcc
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-02-19 16:17:33 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-02-19 16:17:33 +0000
commitf55e1cd950a96045de381abedde9e2727d001234 (patch)
tree31c642152a1e8456d85bfa1bea0bbdc0db39e674 /packages/gcc
parent18bae0d61ca9ad3cb8970bbeedef55ad328bb422 (diff)
parentd69d798924c7d9e543f7078e611ee8c410f2fad6 (diff)
merge of '4f1c373d43a7c1b912b21780d67df8ccec796116'
and 'd684223b6fbdf20a18d598446664827707b7dd91'
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch4
-rw-r--r--packages/gcc/gcc-4.1.2/zecke-xgcc-cpp.patch4
-rw-r--r--packages/gcc/gcc-4.2.1/zecke-no-host-includes.patch13
-rw-r--r--packages/gcc/gcc-4.2.1/zecke-xgcc-cpp.patch4
-rw-r--r--packages/gcc/gcc-4.2.2/zecke-xgcc-cpp.patch4
-rw-r--r--packages/gcc/gcc-package.inc4
-rw-r--r--packages/gcc/gcc_4.2.2.bb1
7 files changed, 34 insertions, 0 deletions
diff --git a/packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch
index 42ec190600..921cab6e18 100644
--- a/packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-4.1.1/zecke-xgcc-cpp.patch
@@ -1,3 +1,7 @@
+upstream: n/a
+comment: Use the preprocessor we have just compiled instead the one of
+the system. There might be incompabilities between us and them.
+
Index: gcc-4.1.1/Makefile.in
===================================================================
--- gcc-4.1.1.orig/Makefile.in 2006-08-06 13:32:44.000000000 +0200
diff --git a/packages/gcc/gcc-4.1.2/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.1.2/zecke-xgcc-cpp.patch
index 42ec190600..921cab6e18 100644
--- a/packages/gcc/gcc-4.1.2/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-4.1.2/zecke-xgcc-cpp.patch
@@ -1,3 +1,7 @@
+upstream: n/a
+comment: Use the preprocessor we have just compiled instead the one of
+the system. There might be incompabilities between us and them.
+
Index: gcc-4.1.1/Makefile.in
===================================================================
--- gcc-4.1.1.orig/Makefile.in 2006-08-06 13:32:44.000000000 +0200
diff --git a/packages/gcc/gcc-4.2.1/zecke-no-host-includes.patch b/packages/gcc/gcc-4.2.1/zecke-no-host-includes.patch
index 6afb10d6ef..0b401defd8 100644
--- a/packages/gcc/gcc-4.2.1/zecke-no-host-includes.patch
+++ b/packages/gcc/gcc-4.2.1/zecke-no-host-includes.patch
@@ -1,3 +1,16 @@
+upstream: n/a
+status: evil hack
+comment: Including host system headers when cross compiling can lead to weird
+issues, in the best case compile issues, in the worst case crashes. E.g. if you
+are building a uclibc system, you certainly do not want glibc headers or OSX libc
+headers to be picked up. To avoid that this patch is penetalizing certain common
+Linux/Unix host directories.
+
+To send the patch upstream the evil paths should be specified by
+a setting or command-line options. Until now this is a evil hack assuming
+certain host system paths. E.g. /usr/local/ and other common paths should be
+added.
+
Index: gcc-4.0.2/gcc/c-incpath.c
===================================================================
--- gcc-4.0.2.orig/gcc/c-incpath.c 2005-01-23 16:05:27.000000000 +0100
diff --git a/packages/gcc/gcc-4.2.1/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.2.1/zecke-xgcc-cpp.patch
index 42ec190600..921cab6e18 100644
--- a/packages/gcc/gcc-4.2.1/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-4.2.1/zecke-xgcc-cpp.patch
@@ -1,3 +1,7 @@
+upstream: n/a
+comment: Use the preprocessor we have just compiled instead the one of
+the system. There might be incompabilities between us and them.
+
Index: gcc-4.1.1/Makefile.in
===================================================================
--- gcc-4.1.1.orig/Makefile.in 2006-08-06 13:32:44.000000000 +0200
diff --git a/packages/gcc/gcc-4.2.2/zecke-xgcc-cpp.patch b/packages/gcc/gcc-4.2.2/zecke-xgcc-cpp.patch
index 42ec190600..921cab6e18 100644
--- a/packages/gcc/gcc-4.2.2/zecke-xgcc-cpp.patch
+++ b/packages/gcc/gcc-4.2.2/zecke-xgcc-cpp.patch
@@ -1,3 +1,7 @@
+upstream: n/a
+comment: Use the preprocessor we have just compiled instead the one of
+the system. There might be incompabilities between us and them.
+
Index: gcc-4.1.1/Makefile.in
===================================================================
--- gcc-4.1.1.orig/Makefile.in 2006-08-06 13:32:44.000000000 +0200
diff --git a/packages/gcc/gcc-package.inc b/packages/gcc/gcc-package.inc
index d1b4607de5..3d57d01113 100644
--- a/packages/gcc/gcc-package.inc
+++ b/packages/gcc/gcc-package.inc
@@ -12,6 +12,10 @@ PACKAGES = "libgcc ${PN} ${PN}-symlinks \
libstdc++-dev libg2c-dev \
${PN}-doc"
+# We really need HOST_SYS here for some packages and TARGET_SYS for others.
+# For now, libgcc is most important so we fix for that - RP.
+SHLIBSDIR = "${STAGING_DIR}/${TARGET_SYS}/shlibs"
+
FILES_${PN} = "${bindir}/${TARGET_PREFIX}gcc \
${bindir}/${TARGET_PREFIX}gccbug \
${libexecdir}/gcc/${TARGET_SYS}/${BINV}/cc1 \
diff --git a/packages/gcc/gcc_4.2.2.bb b/packages/gcc/gcc_4.2.2.bb
index 15a25c9c6a..dea9f14d9a 100644
--- a/packages/gcc/gcc_4.2.2.bb
+++ b/packages/gcc/gcc_4.2.2.bb
@@ -27,6 +27,7 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://602-sdk-libstdc++-includes.patch;patch=1 \
file://740-sh-pr24836.patch;patch=1 \
file://800-arm-bigendian.patch;patch=1 \
+ file://801-arm-bigendian-eabi.patch;patch=1 \
file://904-flatten-switch-stmt-00.patch;patch=1 \
file://arm-nolibfloat.patch;patch=1 \
file://arm-softfloat.patch;patch=1 \