summaryrefslogtreecommitdiff
path: root/packages/gcc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-10-31 18:46:24 +0000
committerKoen Kooi <koen@openembedded.org>2007-10-31 18:46:24 +0000
commit3b0d162d85977a2ae198e0cc6060b051408375ed (patch)
tree5b7292d824b225054823541030fa64b7ba05a4d6 /packages/gcc
parent84b2b31930881004a73267cf24fe6fe701e0f8a8 (diff)
gcc: move avr32 stuff into gcc recipe and update to 4.2.1
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/avr32-gcc-cross_4.1.2.bb22
-rw-r--r--packages/gcc/avr32-gcc_4.1.2.bb24
-rw-r--r--packages/gcc/gcc_4.2.1.bb30
3 files changed, 28 insertions, 48 deletions
diff --git a/packages/gcc/avr32-gcc-cross_4.1.2.bb b/packages/gcc/avr32-gcc-cross_4.1.2.bb
deleted file mode 100644
index 765619ad69..0000000000
--- a/packages/gcc/avr32-gcc-cross_4.1.2.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-require avr32-gcc_${PV}.bb
-# path mangling, needed by the cross packaging
-require gcc-paths-cross.inc
-inherit cross
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
-# NOTE: split PR. If the main .oe changes something that affects its *build*
-# remember to increment this one too.
-PR = "r1"
-
-DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
-PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
-
-# cross build
-require gcc3-build-cross.inc
-# cross packaging
-require gcc-package-cross.inc
-
-SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
-
-EXTRA_OECONF += " --disable-libmudflap \
- --disable-libunwind-exceptions \
- --with-mpfr=${STAGING_DIR}/${BUILD_SYS}"
diff --git a/packages/gcc/avr32-gcc_4.1.2.bb b/packages/gcc/avr32-gcc_4.1.2.bb
deleted file mode 100644
index fd461728bd..0000000000
--- a/packages/gcc/avr32-gcc_4.1.2.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-require gcc_${PV}.bb
-
-PR = "r1"
-
-FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/gcc-4.1.2', '${FILE_DIRNAME}/gcc', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
-
-SRC_URI = "http://www.angstrom-distribution.org/unstable/sources/gcc-4.1.2-atmel.1.1.0.tar.gz \
-# file://100-uclibc-conf.patch;patch=1 \
-# file://200-uclibc-locale.patch;patch=1 \
-# file://300-libstdc++-pic.patch;patch=1 \
- file://301-missing-execinfo_h.patch;patch=1 \
- file://302-c99-snprintf.patch;patch=1 \
- file://303-c99-complex-ugly-hack.patch;patch=1 \
- file://304-index_macro.patch;patch=1 \
- file://602-sdk-libstdc++-includes.patch;patch=1 \
- file://gcc41-configure.in.patch;patch=1 \
- file://ldflags.patch;patch=1 \
- file://zecke-xgcc-cpp.patch;patch=1 \
- file://cache-amnesia.patch;patch=1 \
- "
-
-do_compile_prepend() {
-ln -sf ${S}/libstdc++-v3/config/os/uclibc/ ${S}/libstdc++-v3/config/os/uclibc-linux
-}
diff --git a/packages/gcc/gcc_4.2.1.bb b/packages/gcc/gcc_4.2.1.bb
index 7bf074de57..af90755c3b 100644
--- a/packages/gcc/gcc_4.2.1.bb
+++ b/packages/gcc/gcc_4.2.1.bb
@@ -1,4 +1,4 @@
-PR = "r5"
+PR = "r6"
DESCRIPTION = "The GNU cc and gcc C compilers."
HOMEPAGE = "http://www.gnu.org/software/gcc/"
SECTION = "devel"
@@ -41,6 +41,32 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://gfortran.patch;patch=1 \
"
+SRC_URI_avr32 = " http://ewi546.ewi.utwente.nl/tmp/avr32-gcc-4.2.1-atmel.1.0.1.tar.gz \
+ file://100-uclibc-conf.patch;patch=1 \
+ file://103-uclibc-conf-noupstream.patch;patch=1 \
+ file://200-uclibc-locale.patch;patch=1 \
+ file://203-uclibc-locale-no__x.patch;patch=1 \
+ file://204-uclibc-locale-wchar_fix.patch;patch=1 \
+ file://205-uclibc-locale-update.patch;patch=1 \
+ file://300-libstdc++-pic.patch;patch=1 \
+ file://301-missing-execinfo_h.patch;patch=1 \
+ file://302-c99-snprintf.patch;patch=1 \
+ file://303-c99-complex-ugly-hack.patch;patch=1 \
+ file://304-index_macro.patch;patch=1 \
+ file://305-libmudflap-susv3-legacy.patch;patch=1 \
+ file://306-libstdc++-namespace.patch;patch=1 \
+ file://307-locale_facets.patch;patch=1 \
+ file://402-libbackend_dep_gcov-iov.h.patch;patch=1 \
+ file://602-sdk-libstdc++-includes.patch;patch=1 \
+ file://740-sh-pr24836.patch;patch=1 \
+ file://904-flatten-switch-stmt-00.patch;patch=1 \
+ file://gcc41-configure.in.patch;patch=1 \
+ file://ldflags.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1 \
+ file://cache-amnesia.patch;patch=1 \
+ file://gfortran.patch;patch=1 \
+"
+
SRC_URI_append_ep93xx = " \
file://arm-crunch-saveregs.patch;patch=1 \
file://arm-crunch-20000320.patch;patch=1 \
@@ -79,5 +105,5 @@ require gcc3-build.inc
ARCH_FLAGS_FOR_TARGET=-isystem${STAGING_INCDIR}
-EXTRA_OECONF += " --disable-libssp --disable-bootstrap "
+EXTRA_OECONF += " --disable-libgomp --disable-libssp --disable-bootstrap "