summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc_4.2.2.bb
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2008-01-17 14:05:03 +0000
committerHolger Freyther <zecke@selfish.org>2008-01-17 14:05:03 +0000
commit898c5fa4f1a22a909b898dd018b1d19e8f7b3db4 (patch)
tree3897ae110eb636314f15a467ef3bcc80565d1c5d /packages/gcc/gcc_4.2.2.bb
parente8a60c1e518ddfeb5b5b913c3631b5daa56f6dad (diff)
* Use static linking for mpfr/gmp instead of the rpath. This avoid the layering
violation and makes sure that gcc-cross-sdk will build as well. * For gcc4.3 we need to look at the gmp/mpfr again as they will be required for everything and not just gfortran * Apply a patch to gcc_4.2.2 but only if we want to build gcc. We want to be able to use arm-angstrom-linux-gnueabi-gfortran and the GF="$(GFORTRAN)" would have set the fortran to 'gfortran' and we ended up with a build error. Some more experiments with GFORTRAN_FOR_TARGET are needed.
Diffstat (limited to 'packages/gcc/gcc_4.2.2.bb')
-rw-r--r--packages/gcc/gcc_4.2.2.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/packages/gcc/gcc_4.2.2.bb b/packages/gcc/gcc_4.2.2.bb
index 91f4691208..15a25c9c6a 100644
--- a/packages/gcc/gcc_4.2.2.bb
+++ b/packages/gcc/gcc_4.2.2.bb
@@ -41,6 +41,7 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
file://gfortran.patch;patch=1 \
file://gcc-4.0.2-e300c2c3.patch;patch=1 \
file://pr34130.patch;patch=1 \
+ file://fortran-static-linking.patch;patch=1 \
"
SRC_URI_append_ep93xx = " \
@@ -72,6 +73,8 @@ SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
FORTRAN = ""
FORTRAN_linux-gnueabi = ",fortran"
+DEPENDS += " gmp mpfr "
+
#Set the java bits
JAVA = ""
JAVA_arm = ""
@@ -83,3 +86,9 @@ ARCH_FLAGS_FOR_TARGET=-isystem${STAGING_INCDIR}
EXTRA_OECONF += " --disable-libssp --disable-bootstrap "
+# We know some one is including us, but we only want to apply this fortran hack for the real gcc
+python __anonymous () {
+ import bb
+ if bb.data.getVar('PN', d, True) == "gcc":
+ bb.data.setVar('SRC_URI_append', ' file://fortran-cross-compile-hack.patch;patch=1', d)
+}