summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc_4.1.2.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-03-06 12:29:32 +0000
committerKoen Kooi <koen@openembedded.org>2007-03-06 12:29:32 +0000
commitd7075380c4eb2d376f4c95e88b892575ba6a2924 (patch)
tree8959feb3af281c312ca192bb67ba66b811374204 /packages/gcc/gcc_4.1.2.bb
parent4ad49843073f688aabd85ad240f1efa082179e20 (diff)
gcc: add 4.1.2, only tested to compile for arm/eabi
Diffstat (limited to 'packages/gcc/gcc_4.1.2.bb')
-rw-r--r--packages/gcc/gcc_4.1.2.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/packages/gcc/gcc_4.1.2.bb b/packages/gcc/gcc_4.1.2.bb
new file mode 100644
index 0000000000..91f6624aa1
--- /dev/null
+++ b/packages/gcc/gcc_4.1.2.bb
@@ -0,0 +1,53 @@
+PR = "r0"
+DESCRIPTION = "The GNU cc and gcc C compilers."
+HOMEPAGE = "http://www.gnu.org/software/gcc/"
+SECTION = "devel"
+LICENSE = "GPL"
+
+inherit autotools gettext
+
+require gcc-package.inc
+
+SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.2/gcc-4.1.2.tar.bz2 \
+ file://100-uclibc-conf.patch;patch=1 \
+ file://110-arm-eabi.patch;patch=1 \
+ file://200-uclibc-locale.patch;patch=1 \
+ file://300-libstdc++-pic.patch;patch=1 \
+ file://301-missing-execinfo_h.patch;patch=1 \
+ file://302-c99-snprintf.patch;patch=1 \
+ file://303-c99-complex-ugly-hack.patch;patch=1 \
+ file://304-index_macro.patch;patch=1 \
+ file://602-sdk-libstdc++-includes.patch;patch=1 \
+ file://740-sh-pr24836.patch;patch=1 \
+ file://800-arm-bigendian.patch;patch=1 \
+ file://801-arm-bigendian-eabi.patch;patch=1 \
+ file://arm-nolibfloat.patch;patch=1 \
+ file://arm-softfloat.patch;patch=1 \
+ file://gcc41-configure.in.patch;patch=1 \
+ file://arm-thumb.patch;patch=1 \
+ file://arm-thumb-cache.patch;patch=1 \
+ file://ldflags.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1 \
+ file://unbreak-armv4t.patch;patch=1 \
+ file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
+ "
+
+SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
+SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
+
+#Set the fortran bits
+# 'fortran' or '', not 'f77' like gcc3 had
+FORTRAN = ""
+HAS_GFORTRAN = "no"
+HAS_G2C = "no"
+
+#Set the java bits
+JAVA_arm = ""
+JAVA = ""
+
+LANGUAGES = "c,c++${FORTRAN}${JAVA}"
+require gcc3-build.inc
+
+
+EXTRA_OECONF += " --disable-libssp "
+