summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc_4.1.2.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-10-20 15:48:00 +0000
committerKoen Kooi <koen@openembedded.org>2007-10-20 15:48:00 +0000
commit1466348a03b6af7034ca91618a74a33e5665540b (patch)
tree50954e74709479ce5a62e1a2f53eb385b6a6885a /packages/gcc/gcc_4.1.2.bb
parent1c5df3f485ba9992931e06d07f28c57a29d89e5e (diff)
gcc: merge avr32 bits into proper gcc files
Diffstat (limited to 'packages/gcc/gcc_4.1.2.bb')
-rw-r--r--packages/gcc/gcc_4.1.2.bb21
1 files changed, 20 insertions, 1 deletions
diff --git a/packages/gcc/gcc_4.1.2.bb b/packages/gcc/gcc_4.1.2.bb
index 5d01163d94..8c6dc524df 100644
--- a/packages/gcc/gcc_4.1.2.bb
+++ b/packages/gcc/gcc_4.1.2.bb
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "r7"
DESCRIPTION = "The GNU cc and gcc C compilers."
HOMEPAGE = "http://www.gnu.org/software/gcc/"
SECTION = "devel"
@@ -35,6 +35,25 @@ SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.2/gcc-4.1.2.tar.bz2 \
SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
+SRC_URI_avr32 = "http://www.angstrom-distribution.org/unstable/sources/gcc-4.1.2-atmel.1.1.0.tar.gz \
+# file://100-uclibc-conf.patch;patch=1 \
+# file://200-uclibc-locale.patch;patch=1 \
+# file://300-libstdc++-pic.patch;patch=1 \
+ file://301-missing-execinfo_h.patch;patch=1 \
+ file://302-c99-snprintf.patch;patch=1 \
+ file://303-c99-complex-ugly-hack.patch;patch=1 \
+ file://304-index_macro.patch;patch=1 \
+ file://602-sdk-libstdc++-includes.patch;patch=1 \
+ file://gcc41-configure.in.patch;patch=1 \
+ file://ldflags.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1 \
+ file://cache-amnesia.patch;patch=1 \
+ "
+
+do_compile_prepend_avr32() {
+ ln -sf ${S}/libstdc++-v3/config/os/uclibc/ ${S}/libstdc++-v3/config/os/uclibc-linux
+}
+
#Set the fortran bits
# ',fortran' or '', not 'f77' like gcc3 had
FORTRAN = ""