summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc_3.4.3.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-28 18:40:10 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-28 18:40:10 +0000
commit42ef6052de33e911df212fee206aa93c6c06fdc1 (patch)
treeaee85a06a75daff46ca07b93e874f02d136def7a /packages/gcc/gcc_3.4.3.bb
parent3bf6f8c323aa797765ad4039312c32d0dfd39c7f (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2004/12/28 12:24:04-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/openembedded 2004/12/28 12:23:35-06:00 ti.com!kergoth Update to current gcc 3.4.0 visibility patch, which fixes it so that the global new & delete operators are always set to 'default' visibility. BKrev: 41d1a88aaZqVpzw1UEEVWun3uInbcw
Diffstat (limited to 'packages/gcc/gcc_3.4.3.bb')
-rw-r--r--packages/gcc/gcc_3.4.3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/gcc/gcc_3.4.3.bb b/packages/gcc/gcc_3.4.3.bb
index e69de29bb2..5b7b1226ee 100644
--- a/packages/gcc/gcc_3.4.3.bb
+++ b/packages/gcc/gcc_3.4.3.bb
@@ -0,0 +1,25 @@
+PR = "r5"
+DESCRIPTION = "The GNU cc and gcc C compilers."
+HOMEPAGE = "http://www.gnu.org/software/gcc/"
+SECTION = "devel"
+LICENSE = "GPL"
+MAINTAINER = "Gerald Britton <gbritton@doomcom.org>"
+
+inherit autotools gettext
+
+include gcc-package.inc
+
+SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
+ file://gcc34-reverse-compare.patch;patch=1 \
+ file://gcc34-arm-ldm.patch;patch=1 \
+ file://gcc34-arm-ldm-peephole.patch;patch=1 \
+ file://gcc34-arm-tune.patch;patch=1 \
+ file://gcc-3.4.1-uclibc-100-conf.patch;patch=1 \
+ file://gcc-3.4.1-uclibc-200-locale.patch;patch=1 \
+ file://gcc-3.4.0-arm-lib1asm.patch;patch=1 \
+ file://gcc-3.4.0-arm-nolibfloat.patch;patch=1 \
+ file://gcc-3.4.0-arm-bigendian.patch;patch=1 \
+ file://gcc-3.4.0-arm-bigendian-uclibc.patch;patch=1 \
+ file://GCC3.4.0VisibilityPatch.diff;patch=1"
+
+include gcc3-build.inc