summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-cross_4.3.1.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-06-11 00:38:21 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-06-11 00:38:21 +0000
commit5f315f57169b07c470244ba3bed197b1a666a3d2 (patch)
tree1a5ca35049abfddabdde44b0d4040c8c7ea0e069 /packages/gcc/gcc-cross_4.3.1.bb
parent72481692826ab2e76d9b5f6e04101520dc386ce9 (diff)
parent8993f246c593e78038f7422c24897bfd16348945 (diff)
merge of '81ef71fa69009396b145139571c2cbaa3855d705'
and 'e5e89d63d424e7df2e0ca809c9cfd4220f57efaa'
Diffstat (limited to 'packages/gcc/gcc-cross_4.3.1.bb')
-rw-r--r--packages/gcc/gcc-cross_4.3.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross_4.3.1.bb b/packages/gcc/gcc-cross_4.3.1.bb
new file mode 100644
index 0000000000..382a234816
--- /dev/null
+++ b/packages/gcc/gcc-cross_4.3.1.bb
@@ -0,0 +1,18 @@
+PR = "r7"
+
+require gcc-${PV}.inc
+require gcc-cross4.inc
+require gcc-configure-cross.inc
+require gcc-package-cross.inc
+
+SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
+
+EXTRA_OECONF += " --enable-cheaders=c_std --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+
+# Hack till we fix *libc properly
+do_stage_append() {
+ ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
+}
+
+
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}"