summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-cross_4.3.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-06-10 22:05:00 +0000
committerKoen Kooi <koen@openembedded.org>2008-06-10 22:05:00 +0000
commit8993f246c593e78038f7422c24897bfd16348945 (patch)
treeb4a9ca8f6b8aade32e15e5e56b23d647442b744f /packages/gcc/gcc-cross_4.3.1.bb
parent0985e00d9608d3f197772046763e03a00a72cd5e (diff)
gcc 4.3.0: replace with gcc 4.3.1
Diffstat (limited to 'packages/gcc/gcc-cross_4.3.1.bb')
-rw-r--r--packages/gcc/gcc-cross_4.3.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross_4.3.1.bb b/packages/gcc/gcc-cross_4.3.1.bb
new file mode 100644
index 0000000000..382a234816
--- /dev/null
+++ b/packages/gcc/gcc-cross_4.3.1.bb
@@ -0,0 +1,18 @@
+PR = "r7"
+
+require gcc-${PV}.inc
+require gcc-cross4.inc
+require gcc-configure-cross.inc
+require gcc-package-cross.inc
+
+SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
+
+EXTRA_OECONF += " --enable-cheaders=c_std --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"
+
+# Hack till we fix *libc properly
+do_stage_append() {
+ ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
+}
+
+
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}"