summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-cross_4.2.2.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-10-10 08:55:35 +0000
committerKoen Kooi <koen@openembedded.org>2007-10-10 08:55:35 +0000
commit7cd1f1a619ec4e88523e2ed850495ef1b616e415 (patch)
tree01beb57731afdd26b85100196f8736224df5baaf /packages/gcc/gcc-cross_4.2.2.bb
parent2b562cb2c7e5c6520d2d0cf972cec1e2d10610eb (diff)
gcc: add 4.2.2
Diffstat (limited to 'packages/gcc/gcc-cross_4.2.2.bb')
-rw-r--r--packages/gcc/gcc-cross_4.2.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross_4.2.2.bb b/packages/gcc/gcc-cross_4.2.2.bb
new file mode 100644
index 0000000000..9025a98f3c
--- /dev/null
+++ b/packages/gcc/gcc-cross_4.2.2.bb
@@ -0,0 +1,20 @@
+require gcc_${PV}.bb
+# path mangling, needed by the cross packaging
+require gcc-paths-cross.inc
+inherit cross
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
+# NOTE: split PR. If the main .oe changes something that affects its *build*
+# remember to increment this one too.
+PR = "r1"
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
+
+# cross build
+require gcc3-build-cross.inc
+# cross packaging
+require gcc-package-cross.inc
+
+SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
+
+EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR}/${BUILD_SYS}"