summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-cross_4.2.2.bb
diff options
context:
space:
mode:
authorOpenmoko anonymizer key <devel@lists.openmoko.org>2007-10-10 10:17:41 +0000
committerOpenmoko anonymizer key <devel@lists.openmoko.org>2007-10-10 10:17:41 +0000
commit10873a2c35c9225f04853a323c8e01559e5a9034 (patch)
tree5a087efe3a3709bce064466027b4a06c02dcbb3f /packages/gcc/gcc-cross_4.2.2.bb
parent9794ad6e78a6a7f5f6b26aaa0494558b7d73e81b (diff)
parent2eb5a3d80018bcfb02586f03f22745d50e327547 (diff)
merge of '320ea19bc463d1bf9e280cbcadba04f87a928ede'
and 'fd564937a9d082f3ea9dd580636ab959f5d77258'
Diffstat (limited to 'packages/gcc/gcc-cross_4.2.2.bb')
-rw-r--r--packages/gcc/gcc-cross_4.2.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross_4.2.2.bb b/packages/gcc/gcc-cross_4.2.2.bb
new file mode 100644
index 0000000000..9025a98f3c
--- /dev/null
+++ b/packages/gcc/gcc-cross_4.2.2.bb
@@ -0,0 +1,20 @@
+require gcc_${PV}.bb
+# path mangling, needed by the cross packaging
+require gcc-paths-cross.inc
+inherit cross
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
+# NOTE: split PR. If the main .oe changes something that affects its *build*
+# remember to increment this one too.
+PR = "r1"
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
+
+# cross build
+require gcc3-build-cross.inc
+# cross packaging
+require gcc-package-cross.inc
+
+SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
+
+EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR}/${BUILD_SYS}"