summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-cross_4.1.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-05-25 16:34:58 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-25 16:34:58 +0000
commitaf10842f3a8a80c39d97ca7aa725ae9fb24fd195 (patch)
treeb1edce0348b214b1f0f5e03eab1c0933360f4987 /packages/gcc/gcc-cross_4.1.1.bb
parent579d6238e817ea11c8b7b09aff2cf36c71027173 (diff)
gcc: add gcc 4.1.1 toolchain
Diffstat (limited to 'packages/gcc/gcc-cross_4.1.1.bb')
-rw-r--r--packages/gcc/gcc-cross_4.1.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross_4.1.1.bb b/packages/gcc/gcc-cross_4.1.1.bb
new file mode 100644
index 0000000000..4b0b5a1311
--- /dev/null
+++ b/packages/gcc/gcc-cross_4.1.1.bb
@@ -0,0 +1,18 @@
+include gcc_${PV}.bb
+# path mangling, needed by the cross packaging
+include gcc-paths-cross.inc
+inherit cross
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
+# NOTE: split PR. If the main .oe changes something that affects its *build*
+# remember to increment this one too.
+PR = "r1"
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
+
+# cross build
+include gcc3-build-cross.inc
+# cross packaging
+include gcc-package-cross.inc
+
+EXTRA_OECONF += "--with-mpfr=${STAGING_DIR}/${BUILD_SYS}"