summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-cross_4.0.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2005-11-14 15:33:41 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-14 15:33:41 +0000
commit401c2566de3debb224b44fdec8d878b2c83738f2 (patch)
treee547208bbd4107d26261b6b420680677dc835600 /packages/gcc/gcc-cross_4.0.2.bb
parent824295f3609d4c5e76ca153756e41406d81f0534 (diff)
gcc: Add version 4.0.2. Known to at least compile code on softfloat arm.
Diffstat (limited to 'packages/gcc/gcc-cross_4.0.2.bb')
-rw-r--r--packages/gcc/gcc-cross_4.0.2.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross_4.0.2.bb b/packages/gcc/gcc-cross_4.0.2.bb
new file mode 100644
index 0000000000..6e299e8299
--- /dev/null
+++ b/packages/gcc/gcc-cross_4.0.2.bb
@@ -0,0 +1,16 @@
+include gcc_${PV}.bb
+# path mangling, needed by the cross packaging
+include gcc-paths-cross.inc
+inherit cross
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
+# NOTE: split PR. If the main .oe changes something that affects its *build*
+# remember to increment this one too.
+PR = "r1"
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
+
+# cross build
+include gcc3-build-cross.inc
+# cross packaging
+include gcc-package-cross.inc