summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-cross_3.4.3.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-28 18:40:10 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-28 18:40:10 +0000
commit42ef6052de33e911df212fee206aa93c6c06fdc1 (patch)
treeaee85a06a75daff46ca07b93e874f02d136def7a /packages/gcc/gcc-cross_3.4.3.bb
parent3bf6f8c323aa797765ad4039312c32d0dfd39c7f (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2004/12/28 12:24:04-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/openembedded 2004/12/28 12:23:35-06:00 ti.com!kergoth Update to current gcc 3.4.0 visibility patch, which fixes it so that the global new & delete operators are always set to 'default' visibility. BKrev: 41d1a88aaZqVpzw1UEEVWun3uInbcw
Diffstat (limited to 'packages/gcc/gcc-cross_3.4.3.bb')
-rw-r--r--packages/gcc/gcc-cross_3.4.3.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross_3.4.3.bb b/packages/gcc/gcc-cross_3.4.3.bb
index e69de29bb2..64095d77e5 100644
--- a/packages/gcc/gcc-cross_3.4.3.bb
+++ b/packages/gcc/gcc-cross_3.4.3.bb
@@ -0,0 +1,14 @@
+include gcc_${PV}.bb
+inherit cross
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
+# NOTE: split PR. If the main .oe changes something that affects its *build*
+# remember to increment this one too.
+PR = "r5"
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
+
+# Files for these are defined in the main gcc.oe
+PACKAGES = "libgcc libstdc++ libg2c"
+
+include gcc3-cross-build.inc