summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-cross-intermediate_csl-arm-2007q3.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2008-07-25 01:12:06 +0000
committerKhem Raj <raj.khem@gmail.com>2008-07-25 01:12:06 +0000
commite96e82cd7ee95d712e2c68f2f9540bdfe727645b (patch)
tree39cdeb09343849bef85eba68c048b9f3b670ac9b /packages/gcc/gcc-cross-intermediate_csl-arm-2007q3.bb
parenta3e73146adce111fe67af0886a43acbf7a654bd7 (diff)
Change the toolchain build sequence. Helps in reproducable toolchains components when recompiled. Also same sequence for all different combinations (uclibc/nptl/eglibc/glibc/linuxthreads). Also fixes and patches that I worked to get various ancient compilers working.
Diffstat (limited to 'packages/gcc/gcc-cross-intermediate_csl-arm-2007q3.bb')
-rw-r--r--packages/gcc/gcc-cross-intermediate_csl-arm-2007q3.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross-intermediate_csl-arm-2007q3.bb b/packages/gcc/gcc-cross-intermediate_csl-arm-2007q3.bb
new file mode 100644
index 0000000000..114d9831c6
--- /dev/null
+++ b/packages/gcc/gcc-cross-intermediate_csl-arm-2007q3.bb
@@ -0,0 +1,12 @@
+require gcc-cross_${PV}.bb
+require gcc-cross-intermediate.inc
+
+S = "${WORKDIR}/gcc-4.2"
+
+EXTRA_OECONF += "--disable-libssp --disable-bootstrap --disable-libgomp --disable-libmudflap "
+
+# Hack till we fix *libc properly
+do_stage_append() {
+ ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
+}
+