summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-cross-initial_csl-arm-20050416.bb
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2005-04-18 13:24:26 +0000
committerPhil Blundell <philb@gnu.org>2005-04-18 13:24:26 +0000
commit4cab60055da3f987a6ebdc7e0e03b8d253fa3fb3 (patch)
treecc7985cf990cb5e691962fa342d42097ae772905 /packages/gcc/gcc-cross-initial_csl-arm-20050416.bb
parent0775a76b90833471476caf92057fb2cac742c41f (diff)
use BINV, not PV, in path to libgcc_eh.a
BKrev: 4263b50alX2DdJR0bLGycUioCPz2pg
Diffstat (limited to 'packages/gcc/gcc-cross-initial_csl-arm-20050416.bb')
-rw-r--r--packages/gcc/gcc-cross-initial_csl-arm-20050416.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross-initial_csl-arm-20050416.bb b/packages/gcc/gcc-cross-initial_csl-arm-20050416.bb
index e69de29bb2..48c80864e2 100644
--- a/packages/gcc/gcc-cross-initial_csl-arm-20050416.bb
+++ b/packages/gcc/gcc-cross-initial_csl-arm-20050416.bb
@@ -0,0 +1,28 @@
+include gcc-cross_${PV}.bb
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils"
+DEPENDS += "${@['virtual/${TARGET_PREFIX}libc-initial',''][bb.data.getVar('TARGET_ARCH', d, 1) in ['arm', 'armeb', 'mips', 'mipsel']]}"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc-initial"
+PACKAGES = ""
+
+# This is intended to be a -very- basic config
+EXTRA_OECONF = "--with-local-prefix=${CROSS_DIR}/${TARGET_SYS} \
+ --with-newlib \
+ --disable-shared \
+ --disable-threads \
+ --disable-multilib \
+ --disable-__cxa_atexit \
+ --enable-languages=c \
+ --enable-target-optspace \
+ --program-prefix=${TARGET_PREFIX} \
+ ${@get_gcc_fpu_setting(bb, d)}"
+
+do_stage_prepend () {
+ mkdir -p ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}
+ ln -sf libgcc.a ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/libgcc_eh.a
+}
+
+# Override the method from gcc-cross so we don't try to install libgcc
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}