summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-cross-initial_4.1-20060217.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-03-03 09:53:27 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-03 09:53:27 +0000
commit1be4a88b624560e0106f2ea5fe25959df8fc5fdb (patch)
treefc02b26c52651d28fa9f83aea4fc4537220e6844 /packages/gcc/gcc-cross-initial_4.1-20060217.bb
parent05e3c69563f36b1af44a43d36c0b2a723474b94f (diff)
gcc: add 4.1
* ldflags.patch needs to be more thorough, you need to insert the patch to staging_incdir manually for now * default_preference is real low because of the above * this one has the necessary eabi bits
Diffstat (limited to 'packages/gcc/gcc-cross-initial_4.1-20060217.bb')
-rw-r--r--packages/gcc/gcc-cross-initial_4.1-20060217.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross-initial_4.1-20060217.bb b/packages/gcc/gcc-cross-initial_4.1-20060217.bb
new file mode 100644
index 0000000000..68dafe3f1a
--- /dev/null
+++ b/packages/gcc/gcc-cross-initial_4.1-20060217.bb
@@ -0,0 +1,29 @@
+include gcc-cross_${PV}.bb
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils"
+DEPENDS += "${@['virtual/${TARGET_PREFIX}libc-initial',''][bb.data.getVar('TARGET_ARCH', d, 1) in ['arm', 'armeb', 'mips', 'mipsel']]}"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc-initial"
+PACKAGES = ""
+
+# This is intended to be a -very- basic config
+EXTRA_OECONF = "--with-local-prefix=${CROSS_DIR}/${TARGET_SYS} \
+ --with-newlib \
+ --disable-shared \
+ --disable-threads \
+ --disable-multilib \
+ --disable-__cxa_atexit \
+ --disable-libmudflap \
+ --enable-languages=c \
+ --enable-target-optspace \
+ --program-prefix=${TARGET_PREFIX} \
+ ${@get_gcc_fpu_setting(bb, d)}"
+
+do_stage_prepend () {
+ mkdir -p ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}
+ ln -sf libgcc.a ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/libgcc_eh.a
+}
+
+# Override the method from gcc-cross so we don't try to install libgcc
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}