summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-4.3.2/debian/ignore-comp-fail.dpatch
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-08-28 08:11:21 +0000
committerKoen Kooi <koen@openembedded.org>2008-08-28 08:11:21 +0000
commit36508f4088546d49972d1eda016dfd616de43a46 (patch)
tree2bceae4502ba26f454e6e9e2beafb2b9319567bd /packages/gcc/gcc-4.3.2/debian/ignore-comp-fail.dpatch
parent80cc287288dcefc1a373d6ebd63bd31c6433420a (diff)
gcc* 4.3.2: add skeleton, it is missing sysroot, xgcc and uclibc patches
Diffstat (limited to 'packages/gcc/gcc-4.3.2/debian/ignore-comp-fail.dpatch')
-rw-r--r--packages/gcc/gcc-4.3.2/debian/ignore-comp-fail.dpatch38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/gcc/gcc-4.3.2/debian/ignore-comp-fail.dpatch b/packages/gcc/gcc-4.3.2/debian/ignore-comp-fail.dpatch
new file mode 100644
index 0000000000..4609a82120
--- /dev/null
+++ b/packages/gcc/gcc-4.3.2/debian/ignore-comp-fail.dpatch
@@ -0,0 +1,38 @@
+#! /bin/sh -e
+
+# DP: Ignore the bootstrap comparision failure
+
+dir=
+if [ $# -eq 3 -a "$2" = '-d' ]; then
+ pdir="-d $3"
+ dir="$3/"
+elif [ $# -ne 1 ]; then
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+fi
+case "$1" in
+ -patch)
+ patch $pdir -f --no-backup-if-mismatch -p0 < $0
+ ;;
+ -unpatch)
+ patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
+ ;;
+ *)
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+esac
+exit 0
+
+--- gcc/Makefile.in~ 2004-02-06 08:03:12.000000000 +0100
++++ gcc/Makefile.in 2004-02-14 10:27:19.000000000 +0100
+@@ -3567,7 +3567,9 @@
+ if [ -f .bad_compare ]; then \
+ echo "Bootstrap comparison failure!"; \
+ cat .bad_compare; \
+- exit 1; \
++ echo ""; \
++ echo "Ignore the comparision failure!"; \
++ true; \
+ else \
+ case "$@" in \
+ *-lean ) rm -rf stage$$stage ;; \