summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-4.3.1/debian/libjava-xulrunner1.9.dpatch
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-06-11 00:38:21 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-06-11 00:38:21 +0000
commit5f315f57169b07c470244ba3bed197b1a666a3d2 (patch)
tree1a5ca35049abfddabdde44b0d4040c8c7ea0e069 /packages/gcc/gcc-4.3.1/debian/libjava-xulrunner1.9.dpatch
parent72481692826ab2e76d9b5f6e04101520dc386ce9 (diff)
parent8993f246c593e78038f7422c24897bfd16348945 (diff)
merge of '81ef71fa69009396b145139571c2cbaa3855d705'
and 'e5e89d63d424e7df2e0ca809c9cfd4220f57efaa'
Diffstat (limited to 'packages/gcc/gcc-4.3.1/debian/libjava-xulrunner1.9.dpatch')
-rw-r--r--packages/gcc/gcc-4.3.1/debian/libjava-xulrunner1.9.dpatch41
1 files changed, 41 insertions, 0 deletions
diff --git a/packages/gcc/gcc-4.3.1/debian/libjava-xulrunner1.9.dpatch b/packages/gcc/gcc-4.3.1/debian/libjava-xulrunner1.9.dpatch
new file mode 100644
index 0000000000..19d67d88ba
--- /dev/null
+++ b/packages/gcc/gcc-4.3.1/debian/libjava-xulrunner1.9.dpatch
@@ -0,0 +1,41 @@
+#! /bin/sh -e
+
+# DP: Add configure check for xulrunner-1.9.
+
+dir=
+if [ $# -eq 3 -a "$2" = '-d' ]; then
+ pdir="-d $3"
+ dir="$3/"
+elif [ $# -ne 1 ]; then
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+fi
+case "$1" in
+ -patch)
+ patch $pdir -f --no-backup-if-mismatch -p0 < $0
+ cd ${dir}libjava/classpath && aclocal -I m4 -I ../.. -I ../../config && autoconf
+ ;;
+ -unpatch)
+ patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
+ rm -f ${dir}libjava/configure
+ ;;
+ *)
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+esac
+exit 0
+
+--- libjava/classpath/configure.ac~ 2008-02-22 08:37:10.356094701 +0100
++++ libjava/classpath/configure.ac 2008-02-22 08:38:49.397588719 +0100
+@@ -702,7 +702,10 @@
+
+ dnl Check for plugin support headers and libraries.
+ if test "x${COMPILE_PLUGIN}" = xyes; then
+- PKG_CHECK_MODULES(MOZILLA, mozilla-plugin, [MOZILLA_FOUND=yes], [MOZILLA_FOUND=no])
++ PKG_CHECK_MODULES(MOZILLA, mozilla-plugin libxul-unstable, [MOZILLA_FOUND=yes], [MOZILLA_FOUND=no])
++ if test "x${MOZILLA_FOUND}" = xno; then
++ PKG_CHECK_MODULES(MOZILLA, mozilla-plugin, [MOZILLA_FOUND=yes], [MOZILLA_FOUND=no])
++ fi
+ if test "x${MOZILLA_FOUND}" = xno; then
+ PKG_CHECK_MODULES(MOZILLA, firefox-plugin firefox-xpcom, [MOZILLA_FOUND=yes], [MOZILLA_FOUND=no])
+ fi