summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-4.3.1/debian/cross-include.dpatch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/gcc/gcc-4.3.1/debian/cross-include.dpatch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/gcc/gcc-4.3.1/debian/cross-include.dpatch')
-rw-r--r--packages/gcc/gcc-4.3.1/debian/cross-include.dpatch39
1 files changed, 0 insertions, 39 deletions
diff --git a/packages/gcc/gcc-4.3.1/debian/cross-include.dpatch b/packages/gcc/gcc-4.3.1/debian/cross-include.dpatch
deleted file mode 100644
index c2622903ec..0000000000
--- a/packages/gcc/gcc-4.3.1/debian/cross-include.dpatch
+++ /dev/null
@@ -1,39 +0,0 @@
-#! /bin/sh -e
-
-# DP: Set cross include path to .../include, not .../sys-include
-# DP: This should be a fix for famous limits.h issue
-
-dir=
-if [ $# -eq 3 -a "$2" = '-d' ]; then
- pdir="-d $3"
- dir="$3/"
-elif [ $# -ne 1 ]; then
- echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
- exit 1
-fi
-case "$1" in
- -patch)
- patch $pdir -f --no-backup-if-mismatch -p0 < $0
- cd ${dir}gcc && autoconf
- ;;
- -unpatch)
- patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
- cd ${dir}gcc && autoconf
- ;;
- *)
- echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
- exit 1
-esac
-exit 0
-
---- gcc/configure.ac.orig 2005-08-24 06:24:11.000000000 +0400
-+++ gcc/configure.ac 2005-12-06 00:40:45.000000000 +0300
-@@ -681,7 +681,7 @@
- ], [
- TARGET_SYSTEM_ROOT=
- TARGET_SYSTEM_ROOT_DEFINE=
-- CROSS_SYSTEM_HEADER_DIR='$(gcc_tooldir)/sys-include'
-+ CROSS_SYSTEM_HEADER_DIR='$(prefix)/$(target_noncanonical)/include'
- ])
- AC_SUBST(TARGET_SYSTEM_ROOT)
- AC_SUBST(TARGET_SYSTEM_ROOT_DEFINE)