summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-4.3.1/cache-amnesia.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2008-08-20 23:12:27 +0000
committerKhem Raj <raj.khem@gmail.com>2008-08-20 23:12:27 +0000
commit347f41f1c6caef14cd1a30315a6ce8dd2692da76 (patch)
tree8a0f0163926067e2543ad286f0e9add8daee29f5 /packages/gcc/gcc-4.3.1/cache-amnesia.patch
parent77a319c9b302cd96ad7419c80a4334ae5a71b275 (diff)
Enable gcc 4.3.1 to build for uclibc.
Revive the uclibc locale support. Fix gcc native breakage for 4.3.1.
Diffstat (limited to 'packages/gcc/gcc-4.3.1/cache-amnesia.patch')
-rw-r--r--packages/gcc/gcc-4.3.1/cache-amnesia.patch28
1 files changed, 23 insertions, 5 deletions
diff --git a/packages/gcc/gcc-4.3.1/cache-amnesia.patch b/packages/gcc/gcc-4.3.1/cache-amnesia.patch
index ef7cd111c5..fb4d1a26d8 100644
--- a/packages/gcc/gcc-4.3.1/cache-amnesia.patch
+++ b/packages/gcc/gcc-4.3.1/cache-amnesia.patch
@@ -1,8 +1,26 @@
-diff --git a/gcc/configure b/gcc/configure
-index 44620ab..6e1830c 100755
---- a/gcc/configure
-+++ b/gcc/configure
-@@ -12272,7 +12272,7 @@ else
+---
+ gcc/configure | 2 +-
+ gcc/configure.ac | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+Index: gcc-4.3.1/gcc/configure
+===================================================================
+--- gcc-4.3.1.orig/gcc/configure 2008-08-20 00:27:57.000000000 -0700
++++ gcc-4.3.1/gcc/configure 2008-08-20 00:45:11.000000000 -0700
+@@ -12813,7 +12813,7 @@ else
+ esac
+ saved_CFLAGS="${CFLAGS}"
+ CC="${CC_FOR_BUILD}" CFLAGS="${CFLAGS_FOR_BUILD}" \
+- ${realsrcdir}/configure \
++ CONFIG_SITE= ${realsrcdir}/configure --cache-file=./other.cache \
+ --enable-languages=${enable_languages-all} \
+ --target=$target_alias --host=$build_alias --build=$build_alias
+ CFLAGS="${saved_CFLAGS}"
+Index: gcc-4.3.1/gcc/configure.ac
+===================================================================
+--- gcc-4.3.1.orig/gcc/configure.ac 2008-08-20 00:27:57.000000000 -0700
++++ gcc-4.3.1/gcc/configure.ac 2008-08-20 00:44:52.000000000 -0700
+@@ -1480,7 +1480,7 @@ else
esac
saved_CFLAGS="${CFLAGS}"
CC="${CC_FOR_BUILD}" CFLAGS="${CFLAGS_FOR_BUILD}" \