summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-4.2.2/fortran-static-linking.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/gcc/gcc-4.2.2/fortran-static-linking.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/gcc/gcc-4.2.2/fortran-static-linking.patch')
-rw-r--r--packages/gcc/gcc-4.2.2/fortran-static-linking.patch48
1 files changed, 0 insertions, 48 deletions
diff --git a/packages/gcc/gcc-4.2.2/fortran-static-linking.patch b/packages/gcc/gcc-4.2.2/fortran-static-linking.patch
deleted file mode 100644
index 3dd6321dc3..0000000000
--- a/packages/gcc/gcc-4.2.2/fortran-static-linking.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-f951 (fortran) links to MPFR and GMP of our staging area but when executing
-the command the libs can not be found. Use rpath like all the other apps in
-our staging bin/ directory.
-
-Patch the configure to avoid the regeneration...
-
-Index: gcc-4.2.2/configure
-===================================================================
---- gcc-4.2.2.orig/configure 2008-01-15 23:23:41.000000000 +0100
-+++ gcc-4.2.2/configure 2008-01-15 23:25:20.000000000 +0100
-@@ -2278,14 +2278,14 @@
-
-
- if test "x$with_mpfr" != x; then
-- gmplibs="-L$with_mpfr/lib $gmplibs"
-+ gmplibs="-static -L$with_mpfr/lib $gmplibs"
- gmpinc="-I$with_mpfr/include"
- fi
- if test "x$with_mpfr_include" != x; then
- gmpinc="-I$with_mpfr_include"
- fi
- if test "x$with_mpfr_lib" != x; then
-- gmplibs="-L$with_mpfr_lib $gmplibs"
-+ gmplibs="-static -L$with_mpfr_lib $gmplibs"
- fi
-
- # Specify a location for gmp
-Index: gcc-4.2.2/configure.in
-===================================================================
---- gcc-4.2.2.orig/configure.in 2008-01-15 23:23:41.000000000 +0100
-+++ gcc-4.2.2/configure.in 2008-01-15 23:24:36.000000000 +0100
-@@ -1066,14 +1066,14 @@
- AC_ARG_WITH(mpfr_lib, [ --with-mpfr-lib=PATH Specify the directory for the installed MPFR library])
-
- if test "x$with_mpfr" != x; then
-- gmplibs="-L$with_mpfr/lib $gmplibs"
-+ gmplibs="-static -L$with_mpfr/lib $gmplibs"
- gmpinc="-I$with_mpfr/include"
- fi
- if test "x$with_mpfr_include" != x; then
- gmpinc="-I$with_mpfr_include"
- fi
- if test "x$with_mpfr_lib" != x; then
-- gmplibs="-L$with_mpfr_lib $gmplibs"
-+ gmplibs="-static -L$with_mpfr_lib $gmplibs"
- fi
-
- # Specify a location for gmp