summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-4.2.2/fortran-cross-compile-hack.patch
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2008-01-17 14:05:03 +0000
committerHolger Freyther <zecke@selfish.org>2008-01-17 14:05:03 +0000
commit898c5fa4f1a22a909b898dd018b1d19e8f7b3db4 (patch)
tree3897ae110eb636314f15a467ef3bcc80565d1c5d /packages/gcc/gcc-4.2.2/fortran-cross-compile-hack.patch
parente8a60c1e518ddfeb5b5b913c3631b5daa56f6dad (diff)
* Use static linking for mpfr/gmp instead of the rpath. This avoid the layering
violation and makes sure that gcc-cross-sdk will build as well. * For gcc4.3 we need to look at the gmp/mpfr again as they will be required for everything and not just gfortran * Apply a patch to gcc_4.2.2 but only if we want to build gcc. We want to be able to use arm-angstrom-linux-gnueabi-gfortran and the GF="$(GFORTRAN)" would have set the fortran to 'gfortran' and we ended up with a build error. Some more experiments with GFORTRAN_FOR_TARGET are needed.
Diffstat (limited to 'packages/gcc/gcc-4.2.2/fortran-cross-compile-hack.patch')
-rw-r--r--packages/gcc/gcc-4.2.2/fortran-cross-compile-hack.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/gcc/gcc-4.2.2/fortran-cross-compile-hack.patch b/packages/gcc/gcc-4.2.2/fortran-cross-compile-hack.patch
new file mode 100644
index 0000000000..b3d38ad983
--- /dev/null
+++ b/packages/gcc/gcc-4.2.2/fortran-cross-compile-hack.patch
@@ -0,0 +1,30 @@
+* Fortran would have searched for arm-angstrom-gnueabi-gfortran but would have used
+ used gfortan. For gcc_4.2.2.bb we want to use the gfortran compiler from our cross
+ directory.
+
+diff --git a/libgfortran/configure b/libgfortran/configure
+index f7d86fb..d0966ec 100755
+--- a/libgfortran/configure
++++ b/libgfortran/configure
+@@ -4475,6 +4475,6 @@ exec 5>>./config.log
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ ac_ext=${FC_SRCEXT-f}
+ ac_compile='$FC -c $FCFLAGS $FCFLAGS_SRCEXT conftest.$ac_ext >&5'
+\ No newline at end of file
+diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
+index 4661306..9f83e55 100644
+--- a/libgfortran/configure.ac
++++ b/libgfortran/configure.ac
+@@ -140,7 +140,7 @@ AC_SUBST(enable_static)
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ AC_PROG_FC(gfortran)
+
+ # extra LD Flags which are required for targets