summaryrefslogtreecommitdiff
path: root/packages/gcc/gcc-3.4.3.inc
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2008-03-15 13:39:18 +0000
committerRichard Purdie <rpurdie@rpsys.net>2008-03-15 13:39:18 +0000
commita58b26f88e2a4377e8c22f3a1269672815799c8c (patch)
tree43a04eb7471a46c3e74b8776acb4f715e8e789d4 /packages/gcc/gcc-3.4.3.inc
parent61f76f5ed16476df673e77ecea8113100426eb33 (diff)
gcc: Create .inc files for each gcc version and update all .bb files to use these
Diffstat (limited to 'packages/gcc/gcc-3.4.3.inc')
-rw-r--r--packages/gcc/gcc-3.4.3.inc28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/gcc/gcc-3.4.3.inc b/packages/gcc/gcc-3.4.3.inc
new file mode 100644
index 0000000000..c4d6df955d
--- /dev/null
+++ b/packages/gcc/gcc-3.4.3.inc
@@ -0,0 +1,28 @@
+PR = "r12"
+DESCRIPTION = "The GNU cc and gcc C compilers."
+HOMEPAGE = "http://www.gnu.org/software/gcc/"
+SECTION = "devel"
+LICENSE = "GPL"
+
+inherit autotools gettext
+
+require gcc-package.inc
+
+SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
+ file://gcc34-reverse-compare.patch;patch=1 \
+ file://gcc34-arm-ldm.patch;patch=1 \
+ file://gcc34-arm-ldm-peephole.patch;patch=1 \
+ file://gcc34-arm-tune.patch;patch=1 \
+ file://gcc-3.4.1-uclibc-100-conf.patch;patch=1 \
+ file://gcc-3.4.1-uclibc-200-locale.patch;patch=1 \
+ file://gcc-3.4.0-arm-lib1asm.patch;patch=1 \
+ file://gcc-3.4.0-arm-nolibfloat.patch;patch=1 \
+ file://gcc-3.4.0-arm-bigendian.patch;patch=1 \
+ file://gcc-3.4.0-arm-bigendian-uclibc.patch;patch=1 \
+ file://GCC3.4.0VisibilityPatch.diff;patch=1 \
+ file://15342.patch;patch=1 \
+ file://always-fixincperm.patch;patch=1 \
+ file://GCOV_PREFIX_STRIP-cross-profile_3.4.patch;patch=1 \
+ file://zecke-xgcc-cpp.patch;patch=1 "
+
+require gcc3-build.inc