summaryrefslogtreecommitdiff
path: root/packages/gcc/avr32-gcc-cross_4.1.2.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-09-19 11:32:35 +0000
committerKoen Kooi <koen@openembedded.org>2007-09-19 11:32:35 +0000
commitb2b667e89381c5bee23b9a6e96ccd7f04a15fd1b (patch)
tree320f60bb9ab4410501ef6bff7a9acc2d7f51e04e /packages/gcc/avr32-gcc-cross_4.1.2.bb
parent7006d4aac3bf1eef960d032965ae18f88c4acdfc (diff)
parent85693efa33378405956ca83c7b24d45f5138d223 (diff)
propagate from branch 'org.openembedded.dev' (head 0ba4bbe5ebdf7f3598dd1890a61d14cd356eab54)
to branch 'org.openembedded.dev.avr32' (head d4fef411c5337e77b35acf5e2a06ffb56d059326)
Diffstat (limited to 'packages/gcc/avr32-gcc-cross_4.1.2.bb')
-rw-r--r--packages/gcc/avr32-gcc-cross_4.1.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/gcc/avr32-gcc-cross_4.1.2.bb b/packages/gcc/avr32-gcc-cross_4.1.2.bb
new file mode 100644
index 0000000000..765619ad69
--- /dev/null
+++ b/packages/gcc/avr32-gcc-cross_4.1.2.bb
@@ -0,0 +1,22 @@
+require avr32-gcc_${PV}.bb
+# path mangling, needed by the cross packaging
+require gcc-paths-cross.inc
+inherit cross
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
+# NOTE: split PR. If the main .oe changes something that affects its *build*
+# remember to increment this one too.
+PR = "r1"
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
+
+# cross build
+require gcc3-build-cross.inc
+# cross packaging
+require gcc-package-cross.inc
+
+SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
+
+EXTRA_OECONF += " --disable-libmudflap \
+ --disable-libunwind-exceptions \
+ --with-mpfr=${STAGING_DIR}/${BUILD_SYS}"