summaryrefslogtreecommitdiff
path: root/packages/gammu/gammu_1.17.0.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-12-23 19:33:40 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-12-23 19:33:40 +0000
commitca879040e453c64b80fdcc4d86931f1fe428d955 (patch)
treef1c2fed5a2810729c9060bc6338effac5f217cd1 /packages/gammu/gammu_1.17.0.bb
parent75dabaea1044bc9ceebeae6ed2cec16cddb04b84 (diff)
gammu: updated to 1.17.0
Diffstat (limited to 'packages/gammu/gammu_1.17.0.bb')
-rw-r--r--packages/gammu/gammu_1.17.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/gammu/gammu_1.17.0.bb b/packages/gammu/gammu_1.17.0.bb
new file mode 100644
index 0000000000..fc7adb1b79
--- /dev/null
+++ b/packages/gammu/gammu_1.17.0.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "GNU All Mobile Managment Utilities"
+SECTION = "console/network"
+DEPENDS = "bluez-libs cmake-native"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gammu.org/"
+
+SRC_URI = "http://dl.cihar.com/gammu/releases/gammu-${PV}.tar.bz2 "
+
+inherit pkgconfig
+
+do_configure() {
+ cd ${S} && CMAKE_C_COMPILER=${TARGET_OS}-gcc ./configure --prefix=${prefix} --enable-shared --enable-backup
+}
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/gammu/
+ install -m 0644 build-configure/include/*.h ${STAGING_INCDIR}/gammu/
+
+ oe_libinstall -so -C build-configure/common libGammu ${STAGING_LIBDIR}
+}
+
+PACKAGES =+ "libgammu"
+
+FILES_${PN} = "${bindir}/gammu"
+FILES_libgammu = "${libdir}/libGammu.so*"