summaryrefslogtreecommitdiff
path: root/packages/gammu/gammu_1.13.0.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-08-20 15:32:20 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-08-20 15:32:20 +0000
commit43698063633ea099b64b141e251d12a007977bd2 (patch)
tree7e68db2738686540702c8a0ccbc237de045a7274 /packages/gammu/gammu_1.13.0.bb
parenta2bded6ad1c199dfeef28e27407b7f3ec750db35 (diff)
parent84815b3bdb5039f9ca69606b4a2c66074900d2ac (diff)
merge of '1aa9d5d2291a43dd7550da56fed4507af7db2c81'
and 'e36bd25beb3708ad700892730953005d81ac203b'
Diffstat (limited to 'packages/gammu/gammu_1.13.0.bb')
-rw-r--r--packages/gammu/gammu_1.13.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/gammu/gammu_1.13.0.bb b/packages/gammu/gammu_1.13.0.bb
new file mode 100644
index 0000000000..fc7adb1b79
--- /dev/null
+++ b/packages/gammu/gammu_1.13.0.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "GNU All Mobile Managment Utilities"
+SECTION = "console/network"
+DEPENDS = "bluez-libs cmake-native"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gammu.org/"
+
+SRC_URI = "http://dl.cihar.com/gammu/releases/gammu-${PV}.tar.bz2 "
+
+inherit pkgconfig
+
+do_configure() {
+ cd ${S} && CMAKE_C_COMPILER=${TARGET_OS}-gcc ./configure --prefix=${prefix} --enable-shared --enable-backup
+}
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/gammu/
+ install -m 0644 build-configure/include/*.h ${STAGING_INCDIR}/gammu/
+
+ oe_libinstall -so -C build-configure/common libGammu ${STAGING_LIBDIR}
+}
+
+PACKAGES =+ "libgammu"
+
+FILES_${PN} = "${bindir}/gammu"
+FILES_libgammu = "${libdir}/libGammu.so*"