summaryrefslogtreecommitdiff
path: root/packages/gallery
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/gallery
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/gallery')
-rw-r--r--packages/gallery/files/gallery.conf31
-rw-r--r--packages/gallery/gallery_1.5.5.bb42
2 files changed, 0 insertions, 73 deletions
diff --git a/packages/gallery/files/gallery.conf b/packages/gallery/files/gallery.conf
deleted file mode 100644
index b773e2c24f..0000000000
--- a/packages/gallery/files/gallery.conf
+++ /dev/null
@@ -1,31 +0,0 @@
-<IfDefine PHP5>
-
-<Directory /usr/share/apache2/htdocs/gallery>
-
-php_value post_max_size 20971520
-php_value upload_max_filesize 20971520
-php_value magic_quotes_gpc off
-php_value session.save_handler files
-php_value register_globals off
-
-Options -Indexes +FollowSymLinks
-
-<IfModule mod_rewrite.c>
-RewriteEngine On
-RewriteBase /gallery/
-
-# Ensure that the requested gallery is not a valid directory
-# This can cause an infinite redirection loop
-RewriteCond %{REQUEST_FILENAME} !-d
-RewriteRule ^([^\.\?/]+)/([0-9]+)$ /gallery/view_photo.php?set_albumName=$1/index=$2 [QSA]
-RewriteCond %{REQUEST_FILENAME} !-d
-RewriteRule ^([^\.\?/]+)/([A-Za-z_0-9\-]+)$ /gallery/view_photo.php?set_albumName=$1/id=$2 [QSA]
-RewriteCond %{REQUEST_FILENAME} !-d
-RewriteRule ^([^\.\?/]+)/$ /gallery/$1 [R]
-RewriteCond %{REQUEST_FILENAME} !-d
-RewriteRule ^([^\.\?/]+)$ /gallery/view_album.php?set_albumName=$1 [QSA]
-</IfModule>
-
-</Directory>
-
-</IfDefine>
diff --git a/packages/gallery/gallery_1.5.5.bb b/packages/gallery/gallery_1.5.5.bb
deleted file mode 100644
index 14c7c0f4e0..0000000000
--- a/packages/gallery/gallery_1.5.5.bb
+++ /dev/null
@@ -1,42 +0,0 @@
-DESCRIPTION = "The Gallery v1 web image gallery"
-SECTION = "apps"
-LICENSE = "GPL"
-RDEPENDS = "apache2 modphp imagemagick jhead"
-PR = "r2"
-
-SRC_URI = "http://{SOURCEFORGE_MIRROR}/sourceforge/gallery/gallery-${PV}-pl1.tar.gz"
-
-S = "${WORKDIR}/gallery"
-
-inherit autotools
-
-HTTPCONF = "${sysconfdir}/apache2/httpd.conf"
-DEST_DIR = "${datadir}/apache2/htdocs/"
-
-#
-# don't list the albums as a file - it might get auto-deleted
-#
-FILES_${PN} = "${DEST_DIR}/gallery ${sysconfdir}/apache2/modules.d"
-
-
-# No configure step for gallery
-do_configure() {
- :
-}
-
-# No compile step either
-do_compile() {
- :
-}
-
-#
-do_install() {
- mkdir -p ${D}/${DEST_DIR} ${D}${sysconfdir}/apache2/modules.d
- cp -pPR ${S} ${D}/${DEST_DIR}
- cp ${FILESDIR}/gallery.conf ${D}${sysconfdir}/apache2/modules.d/95_gallery.conf
-}
-
-# remove the gallery code, but not the albums!
-pkg_postrm_${PN}() {
- rm -rf ${DEST_DIR}/gallery /${sysconfdir}/apache2/modules.d/95_gallery.conf
-}