summaryrefslogtreecommitdiff
path: root/packages/fuse/fuse_2.6.3.bb
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2007-03-10 05:00:46 +0000
committerMike Westerhof <mwester@dls.net>2007-03-10 05:00:46 +0000
commitf0538870969c76fea25d8c0b119a28ee6d20268c (patch)
tree7c812c9d0c9be8a49f9b3ea5ec9621f64427cfc9 /packages/fuse/fuse_2.6.3.bb
parentd9ec3df9f83d9285313e0875b4aa2329431f6be6 (diff)
fuse: upgrade to 2.6.3 from upstream; remove dependency on the fuse kernel
module as we wish to use the fuse module provided with recent kernels.
Diffstat (limited to 'packages/fuse/fuse_2.6.3.bb')
-rw-r--r--packages/fuse/fuse_2.6.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/fuse/fuse_2.6.3.bb b/packages/fuse/fuse_2.6.3.bb
new file mode 100644
index 0000000000..f85860f175
--- /dev/null
+++ b/packages/fuse/fuse_2.6.3.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "With FUSE it is possible to implement a fully functional filesystem in a userspace program"
+HOMEPAGE = "http://fuse.sf.net"
+LICENSE = "GPL"
+DEPENDS = "fakeroot-native"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/fuse/${P}.tar.gz \
+ file://not-run-updaterc.d-on-host.patch;patch=1"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = " --disable-kernel-module"
+
+fakeroot do_stage() {
+ autotools_stage_all
+}
+
+# Package the fuse utils and libs in seperate packages
+PACKAGES += "lib${PN} libulockmgr"
+FILES_${PN}-dev += "${libdir}/*.la"
+FILES_lib${PN} = "${libdir}/libfuse*.so.*"
+FILES_libulockmgr = "${libdir}/libulockmgr.so.*"