summaryrefslogtreecommitdiff
path: root/packages/fuse/fuse-module_2.7.2.bb
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2008-02-10 06:18:24 +0000
committerRod Whitby <rod@whitby.id.au>2008-02-10 06:18:24 +0000
commit7e3bf2113c1b327e6792227ba5608fcae5e9cdfa (patch)
tree923f36c9350aca06fd7ff5b75e8ed1d5386456df /packages/fuse/fuse-module_2.7.2.bb
parentceef3d9e48b5c6f02166ad6f2c9d5392a9801d74 (diff)
fuse: Update from 2.7.1 to 2.7.2 so that it builds against 2.6.24 kernel
Diffstat (limited to 'packages/fuse/fuse-module_2.7.2.bb')
-rw-r--r--packages/fuse/fuse-module_2.7.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/fuse/fuse-module_2.7.2.bb b/packages/fuse/fuse-module_2.7.2.bb
new file mode 100644
index 0000000000..48cc33a338
--- /dev/null
+++ b/packages/fuse/fuse-module_2.7.2.bb
@@ -0,0 +1,29 @@
+require fuse.inc
+
+RRECOMMENDS = "fuse"
+PR = "r0"
+
+S = "${WORKDIR}/fuse-${PV}"
+FILES_${PN} = "/dev ${base_libdir}/modules ${sysconfdir}"
+EXTRA_OECONF = " --enable-kernel-module --with-kernel=${STAGING_KERNEL_DIR}"
+
+inherit module
+
+do_configure() {
+ cd ${S} ; oe_runconf
+}
+
+do_compile(){
+ LDFLAGS=""
+ cd ${S}/kernel
+ oe_runmake
+}
+
+fakeroot do_install() {
+ LDFLAGS=""
+ install -d ${D}${sysconfdir}/udev/rules.d/
+ install -m 644 util/udev.rules ${D}${sysconfdir}/udev/rules.d/
+ cd ${S}/kernel
+ oe_runmake install DESTDIR=${D}
+}
+